Bug 851887 - KDE Logout does not Suspend to RAM/Disk
KDE Logout does not Suspend to RAM/Disk
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
17
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-26 18:56 EDT by Peter Gückel
Modified: 2015-07-13 13:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: kde-workspace-4.9.0-6.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-04 09:40:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gückel 2012-08-26 18:56:00 EDT
Description of problem:
When one leaves a KDE session, pressing the leave button opens a drop-down menu that offers 2 options: suspend to RAM and suspend to Disk. These options can no longer, in kde-4.9, be activated.

Version-Release number of selected component (if applicable):
kde-baseapps-4.9.0-1.fc17.x86_64


How reproducible:
Try to log out and suspend the computer.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Suspend (to RAM) used to work in 4.8.
Comment 1 Rex Dieter 2012-08-26 19:39:10 EDT
I can't reproduce.

Are you saying the sleep (suspend to ram) and hibernate (suspend to disk) options aren't selectable (gray'd out) or that clicking does nothing?
Comment 2 Peter Gückel 2012-08-26 22:45:34 EDT
(In reply to comment #1)
> Are you saying the sleep (suspend to ram) and hibernate (suspend to disk)
> options aren't selectable (gray'd out) or that clicking does nothing?

I am saying that when I press and hold the 'turn off computer' button and the suspend options appear, I can move the pointer down over them and each, in turn, greys out, but clicking either does absolutely nothing. Only the very top option, 'turn off computer', has any effect.
Comment 3 Lukáš Tinkl 2012-08-27 03:28:23 EDT
I can reproduce, the items are highlighted (sort of) but can't be activated :/
Comment 4 Daniel Vrátil 2012-08-27 09:14:08 EDT
The issue has been already fixed in upstream. I was able to reproduce it, but after updating to latest HEAD it works.

http://quickgit.kde.org/index.php?p=kde-workspace.git&a=commit&h=23a034c33fadd5148d31ae88e59acf489fbfa618
Comment 5 Rex Dieter 2012-08-27 09:20:05 EDT
Ok, explains why I couldn't reproduce, I used the non-qml kickoff->leave->(sleep|hibernate) as a test.
Comment 6 Daniel Vrátil 2012-08-27 10:49:02 EDT
Sorry, I was referring to incorrect commit. The actual fix is here:

http://quickgit.kde.org/index.php?p=kde-workspace.git&a=commit&h=2519ac36f9218eb267e76d345172dc300c16b019

Will be shipped in KDE 4.9.1.
Comment 7 Peter Gückel 2012-08-27 10:55:59 EDT
That explains it. Both of my computers are affected. Guess I'll have to be patient for 4.9.1 (which can't be that long off).
Comment 8 Lukáš Tinkl 2012-08-27 11:07:02 EDT
I will add it to our git and issue an update
Comment 9 Lukáš Tinkl 2012-09-04 09:40:32 EDT
Fixed in kde-workspace-4.9.0-6.fc18

Note You need to log in before you can comment on or make changes to this bug.