Bug 851888 - yum update to RHUI 2.1 should call pulp-migrate
yum update to RHUI 2.1 should call pulp-migrate
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: mkovacik
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-26 19:18 EDT by Ian Pilcher
Modified: 2013-02-20 12:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 09:57:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Verifying screen log (9.95 KB, text/plain)
2012-08-28 06:59 EDT, mkovacik
no flags Details

  None (edit)
Description Ian Pilcher 2012-08-26 19:18:17 EDT
Description of problem:
When updating from RHUI 2.0.3 to 2.1, it is necessary to manually run
pulp-migrate.  This is not documented, and it should arguably be run as
part of a %post script (pulp?).

Version-Release number of selected component (if applicable):
pulp-0.0.263-25.el6_3.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install RHUI 2.0.3
2. yum update
  
Actual results:
After update, various things will be broken.  Attempting to display the
CDS sync status screen will report an "unexpected error", for example.

Expected results:
pulp-migrate should be run automatically.

Additional info:
Comment 1 James Slagle 2012-08-27 11:58:56 EDT
pulp-migrate won't be run automatically, but I've added the instructions to the README on the iso and we're going to do a new errata and iso for this issue.
Comment 3 James Slagle 2012-08-27 18:10:03 EDT
README updated:

== Updating ==
If updating from RHUI 2.0 or RHUI 2.0.1, make sure to follow all the update
steps detailed in the RHUI 2.0.2 release notes section.

Otherwise, the update steps from the RHUI Installation guide can be followed.

Once the update steps are completed however, the pulp-migrate command needs
to be run and the pulp-server service restarted on the RHUA:

$ pulp-migrate
database migration to version 41 complete
$ service pulp-server restart
Stopping httpd:                                            [  OK  ]
Stopping Qpid AMQP daemon:                                 [  OK  ]
Stopping mongod:                                           [  OK  ]
Starting mongod:                                           [  OK  ]
Starting Qpid AMQP daemon:                                 [  OK  ]
Starting httpd:                                            [  OK  ]

Note: the pulp-migrate command could take up to 1 hour to run.
Comment 5 mkovacik 2012-08-28 06:59:29 EDT
Created attachment 607475 [details]
Verifying screen log

The latest ISO README file does now mention the 'pulp-migrate' step indeed. URL used: https://cdn.redhat.com/content/dist/rhel/rhui/server/6/6Server/x86_64/rhui/2/iso/RHEL-6-RHUI-2-LATEST-Server-x86_64-DVD.iso
Comment 7 errata-xmlrpc 2012-08-29 09:57:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1218.html

Note You need to log in before you can comment on or make changes to this bug.