Bug 85189 - Spassassin init script blocks when run
Spassassin init script blocks when run
Status: CLOSED DUPLICATE of bug 84445
Product: Red Hat Linux
Classification: Retired
Component: spamassassin (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-26 08:56 EST by Keith Sharp
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Sharp 2003-02-26 08:56:54 EST
Description of problem:

When you run the command "/sbin/service spamassassin start" the spamd process
is started but the service command never returns control to the shell.  

On further investigation it looks like the script /etc/init.d/spamassassin tests
for the existance of the file /etc/sysconfig/spamassassin and if it exists it
sources this file.  If the file does not exist then the init script assigns some
default values to the variable $OPTIONS.  These defaults include the "-d" flag
to run the spamd process as a daemon.  $OPTIONS is passed to the spamd process
on line 35 of the init script.

The problem is that the file /etc/sysconfig/spamassassin exists by default, but
uses the variable name $SPAMDOPTIONS rather than $OPTIONS.  This means that the
spamd process is never passed any options, and hence blocks rather than
backgrounding.

The fix would appear to be to use consistent variable names across the two
files: /etc/init.s/spamassassin and /etc/sysconfig/spamassassin.

Version-Release number of selected component (if applicable):

spamassassin-2.44-7.8.x

How reproducible:

Every time.

Steps to Reproduce:
1. run the command "/sbin/service spamassassin start"
2. wait for control to return
3. keep waiting, and waiting......
    
Actual results:

Control never returns to shell from which the spamassassin init script is launched.

Expected results:

The spamd process should be run with the "-d" flag so that control returns to
the shell when  the init script is run.

Additional info:

See above.
Comment 1 Chip Turner 2003-02-26 09:52:35 EST

*** This bug has been marked as a duplicate of 84445 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:51:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.