Bug 851900 - xfburn crashes if a directory is created
xfburn crashes if a directory is created
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfburn (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
: 670131 715516 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-26 22:06 EDT by Ronan Arraes Jardim Chagas
Modified: 2012-12-20 11:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:27:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to correct the bug (1.58 KB, patch)
2012-08-26 22:06 EDT, Ronan Arraes Jardim Chagas
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 6805 None None None 2012-09-28 14:43:07 EDT

  None (edit)
Description Ronan Arraes Jardim Chagas 2012-08-26 22:06:00 EDT
Created attachment 607092 [details]
Patch to correct the bug

Description of problem:

If you create a data composition and add a new directory, then xfburn will crash when you try to burn it.

Version-Release number of selected component (if applicable):

I saw this bug in version 0.4.3 (XFCE 4.10)

How reproducible:

I can reproduce this bug everytime.

Steps to Reproduce:
1. Open xfburn and create a data composition
2. Add a new directory
3. Try to burn it
  
Actual results:

xfburn crashes.

Expected results:

xfburn should open the burn dialog.

Additional info:

This bug was already reported and fixed by upstream (https://bugzilla.xfce.org/show_bug.cgi?id=6805). However xfburn version in Fedora does not have the necessary patch. If Fedora 18 is released with this version, then the attached patch should be applied to correct the aforementioned bug.

I have changed the spec and applied the patch that was attached to this bug (created by manu and posted in the upstream bug report). Everything seems to be ok so far.
Comment 1 Christoph Wickert 2012-09-28 15:02:59 EDT
*** Bug 715516 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Wickert 2012-09-28 15:05:08 EDT
*** Bug 670131 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2012-09-28 22:02:49 EDT
xfburn-0.4.3-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xfburn-0.4.3-10.fc18
Comment 4 Fedora Update System 2012-09-28 22:03:16 EDT
xfburn-0.4.3-10.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xfburn-0.4.3-10.fc17
Comment 5 Fedora Update System 2012-09-28 22:03:36 EDT
xfburn-0.4.3-10.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xfburn-0.4.3-10.fc16
Comment 6 Fedora Update System 2012-09-29 12:22:47 EDT
Package xfburn-0.4.3-10.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfburn-0.4.3-10.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15084/xfburn-0.4.3-10.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-12-20 11:27:12 EST
xfburn-0.4.3-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.