Bug 852 - very old ncr53c8xx.o scsi driver fails
very old ncr53c8xx.o scsi driver fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
http://www.intel.com/design/servers/M...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-16 17:35 EST by mfw
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-15 12:18:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mfw 1999-01-16 17:35:42 EST
the mb440lx has three (3) scsi chips on the motherboard: an
ncr53c810 narrow scsi and two ncr53c875 ultra scsi chips.

linux redhat-5.2-latest boots up cleanly from CD or floppy.
It goes
(quickly) through its installation process.  Then it detects
the scsi
chips.  It installs it's ncr53c8xx.o kernel module. the
module happily
finds the first disk on the first controller (the 810).
Then the
ncr53c8xx.o driver goes to initialize both of the other two
chips.

it goes into an endless loop, displaying the two lines at
the bottom of
this message forever.

i tried all the insmod options that might help from the
README.ncr53c8xx
file from the F2 console (your expert mode dialog box is way
too
small!).
on a different system, i gen'd a kernel with the latest
ncr53c8xx.o
driver built-in (not a module).  i booted to DOS, floppy
sneakernet'd
the kernel and loadlin.exe to the dos partition.  it
booted.  so now i
have a kernel that appears to work (2.0.36 with latest ncr
scsi driver).
i did a loadlin from dos and it appears not to hang.
however it panics
because there is no root partition.

how do i replace the redhat kernel on the redhat boot floppy
with my
working kernel?

i tried to unpack and re-pack the tomsrbt distribution but i
could not
figure out the loop mount weirdism.  i mounted the tomsrbt
floppy and
copied the files back. then i replaced tom's kernel with
mine; however i
did not lilo the floppy so the boot map was wrong and it
froze.

i tried to mount the redhat boot floppy to replace the
bzimage
and lilo the redhat boot floppy, but i could not read the
files on the
redhat boot floppy.

i can get to dos or NT on the scsi drive now.  i did a
loadlin and my
kernel loaded but panicked because it has no root
partition.  i put
umsdos in the kernel (not module) but even if i did copy the
redhat live
image from cd to a dos partition, how would i reformat the
hard drive to
how do i replace the redhat kernel on the redhat boot floppy
with my
working kernel?

i tried to unpack and re-pack the tomsrbt distribution but i
could not
figure out the loop mount weirdism.  i mounted the tomsrbt
floppy and
copied the files back. then i replaced tom's kernel with
mine; however i
did not lilo the floppy so the boot map was wrong and it
froze.

i tried to mount the redhat boot floppy to replace the
bzimage
and lilo the redhat boot floppy, but i could not read the
files on the
redhat boot floppy.

i can get to dos or NT on the scsi drive now.  i did a
loadlin and my
kernel loaded but panicked because it has no root
partition.  i put
umsdos in the kernel (not module) but even if i did copy the
redhat live
image from cd to a dos partition, how would i reformat the
hard drive to
get redhat on the machine natively?


Many thanks in advance,

-mitch          mfw@wyle.org            510.499.4663
Comment 1 Ed Porter 1999-03-20 17:24:59 EST
5.9 (Starbuck iso) failed to find the NCR53C876 pci scsi using it's
ncr53c8xx module. This machine (Compaq Prolient 3000) loaded 5.2 fine
and is currently running kernel 2.2.1-ac5.
Comment 2 Preston Brown 1999-03-29 16:14:59 EST
Matt, what do you know about these NCR cards and the installer? What
more do we need from the user to fix/diagnose the problem more
completely?
Comment 3 Matt Wilson 1999-04-15 12:18:59 EDT
fixed in future release.


------- Email Received From  Mitch Wyle <mfw@datamain.com> 04/15/99 12:24 -------

Note You need to log in before you can comment on or make changes to this bug.