Bug 852001 - Can not register the system with option "--org"
Can not register the system with option "--org"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
high Severity high
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-27 05:50 EDT by xingge
Modified: 2016-09-19 22:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: subscription-manager identity was reporting a database id for the "org id" that was then being misinterpreted by the user as an "org key". Consequence: the user would try to register with --org option passing in an unknown value Fix: changed the value reported by subscription-manager identity to actually report the org key as the "org id". Result: user can now register using the reported org id value
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:59:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhsm.log when bug happened (8.46 KB, text/x-log)
2012-08-27 05:55 EDT, xingge
no flags Details

  None (edit)
Comment 1 xingge 2012-08-27 05:55:14 EDT
Created attachment 607171 [details]
rhsm.log when bug happened
Comment 2 RHEL Product and Program Management 2012-08-27 06:17:07 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Bryan Kearney 2012-08-30 09:14:12 EDT
fixed in master at c27a5df05bdaa7dd985165c9bbbb5ff1631da0ef
Comment 6 John Sefler 2012-09-07 13:48:34 EDT
The value displayed for the org id has been changed from the schema id to the org's key value.  The key is more useful to the user than the id.  The key value is what should be supplied as the value for the --org option when registering.

Verifying Version...
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager
subscription-manager-1.0.17-1.el5

[root@rhsm-accept-rhel5 ~]# subscription-manager config --server.hostname subscription.rhn.stage.redhat.com --server.port 443 --server.prefix /subscription

[root@rhsm-accept-rhel5 ~]# subscription-manager orgs --username=stage_test_12Password: 
+-------------------------------------------+
          stage_test_12 Organizations
+-------------------------------------------+

Name: 	stage_test_12 User
Key: 	6655634

[root@rhsm-accept-rhel5 ~]# subscription-manager register --username=stage_test_12 --org=6655634
Password: 
The system has been registered with id: e7eccf8b-7bc8-49f8-adc9-6f9532b82a89 
[root@rhsm-accept-rhel5 ~]# subscription-manager identity
Current identity is: e7eccf8b-7bc8-49f8-adc9-6f9532b82a89
name: rhsm-accept-rhel5.usersys.redhat.com
org name: stage_test_12 User
org id: 6655634


Movingto VERIFIED
Comment 8 errata-xmlrpc 2013-01-07 22:59:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.