Bug 852005 - ifup-alias doesn't check an IP address for existence
ifup-alias doesn't check an IP address for existence
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 06:03 EDT by Jiri Skala
Modified: 2016-11-25 07:56 EST (History)
6 users (show)

See Also:
Fixed In Version: initscripts-9.03.32-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: No check if address is already used is performed for alias interfaces. Consequence: Already used IP address might be assigned to alias interface. Fix: Check whether the IP is already used or not. Result: Error message is outputted and address is not assigned.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:26:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 891883 None None None Never

  None (edit)
Comment 1 Lukáš Nykrýn 2012-08-28 09:00:57 EDT
I would only replace exit with return, otherwise patch looks sane.
Comment 7 errata-xmlrpc 2013-02-21 05:26:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0518.html

Note You need to log in before you can comment on or make changes to this bug.