Bug 852027 - webadmin: edit/create disk - wipe after delete check box does not appear as checked after pressing ok on disk dialogue although changes are saved
webadmin: edit/create disk - wipe after delete check box does not appear as c...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.0
Assigned To: Tal Nisan
Dafna Ron
storage
: Regression
: 854267 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 07:45 EDT by Dafna Ron
Modified: 2016-02-10 12:47 EST (History)
9 users (show)

See Also:
Fixed In Version: SI19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (2.97 MB, application/x-gzip)
2012-08-27 07:45 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-27 07:45:52 EDT
Created attachment 607187 [details]
logs

Description of problem:

I created and edited several disks and added the wipe after delete tag. 
although the parameter is updated and if we delete the disk is sent to vdsm, it is not saved in UI after we press OK (this is not a timeout issue since I waited several minutes and even logged in and out). 

Version-Release number of selected component (if applicable):

si15

How reproducible:

100%

Steps to Reproduce:
1. create/edit a disk and check the "wipe after delete" check box -> press OK
2. check backend log -> the update is saved
3. edit the disk -> the wipe after delete is not checked. 
4. remove the disk and look for /dev/zero in vdsm log
  
Actual results:

although the option is saved in db and sent to vdsm when we remove the disk the UI is not saving the check box on wipe after delete. 

Expected results:

wipe after delete should be checked

Additional info: logs


I also tested what will happen when my default is wipe after delete. 
it seems that although the check box is marked as checked when we create the disk once we press ok and create the disk the check box disappears. 



when disk is deleted we can see in vdsm log that its is sent as post zeroing: 

root@gold-vdsd ~]# tail -f /var/log/vdsm/vdsm.log |grep /dev/zero

backend log shows that the disk is updated: 

2012-08-27 14:40:29,647 INFO  [org.ovirt.engine.core.bll.UpdateVmDiskCommand] (ajp-/127.0.0.1:8009-10) Lock Acquired to object EngineLock [exclusiveLocks= , sharedLocks= key: 9000ef31-b9bc-4a24-95b1-86273108209b value: VM
]
2012-08-27 14:40:29,649 INFO  [org.ovirt.engine.core.bll.UpdateVmDiskCommand] (pool-4-thread-50) [151f5e5f] Running command: UpdateVmDiskCommand internal: false. Entities affected :  ID: b509a485-8d2a-44b5-bf94-2ad8ea1c5108 Type: Disk
2012-08-27 14:40:29,703 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.UpdateVMVDSCommand] (pool-4-thread-50) [151f5e5f] START, UpdateVMVDSCommand(storagePoolId = a2ade7af-ecc7-44b8-9989-2282d3b59444, ignoreFailoverLimit = false, compatabilityVersion = null, storageDomainId = 00000000-0000-0000-0000-000000000000, infoDictionary.size = 1), log id: 5e876a1f
2012-08-27 14:40:29,745 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.UpdateVMVDSCommand] (pool-4-thread-50) [151f5e5f] FINISH, UpdateVMVDSCommand, log id: 5e876a1f
2012-08-27 14:40:29,808 INFO  [org.ovirt.engine.core.bll.UpdateVmDiskCommand] (pool-4-thread-50) [151f5e5f] Lock freed to object EngineLock [exclusiveLocks= , sharedLocks= key: 9000ef31-b9bc-4a24-95b1-86273108209b value: VM



70f929a5-bc03-49f2-9465-e79e11190325::DEBUG::2012-08-27 14:02:39,329::__init__::1164::Storage.Misc.excCmd::(_log) '/bin/nice -n 19 /usr/bin/ionice -c 2 -n 7 /bin/dd if=/dev/zero of=/dev/663396bd-a19e-4e15-a07d-37e9d3ddc6d2/_remove_me_mKlbNFrX_07739c5c-5fc8-46a3-a33b-3f42e6768d91 bs=1048576 seek=0 skip=0 conv=notrunc count=1024 oflag=direct' (cwd None)



bcb39283-ae25-41ee-b131-1ab0ff343c2c::DEBUG::2012-08-27 14:03:04,890::__init__::1164::Storage.Misc.excCmd::(_log) '/bin/nice -n 19 /usr/bin/ionice -c 2 -n 7 /bin/dd if=/dev/zero of=/dev/663396bd-a19e-4e15-a07d-37e9d3ddc6d2/_remove_me_pyiQSxqn_b8b4d57e-5cab-4608-92c7-f80ca0f4c34e bs=1048576 seek=0 skip=0 conv=notrunc count=10240 oflag=direct' (cwd None)
Comment 2 Ayal Baron 2012-09-05 04:53:44 EDT
*** Bug 854267 has been marked as a duplicate of this bug. ***
Comment 3 Tal Nisan 2012-09-10 11:51:42 EDT
http://gerrit.ovirt.org/7910
Comment 5 Allon Mureinik 2012-09-11 07:32:33 EDT
Merged Ie15a0a5707990fc6e6c317fcddf12bc30bb348ab
Comment 6 Dafna Ron 2012-09-27 06:37:16 EDT
verified on si19

Note You need to log in before you can comment on or make changes to this bug.