Bug 852045 - ulimit -c got Operation not permitted
ulimit -c got Operation not permitted
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sudo (Show other bugs)
6.3
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Kopeček
Aleš Mareček
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 08:32 EDT by Peter Svensson
Modified: 2013-02-21 04:44 EST (History)
4 users (show)

See Also:
Fixed In Version: sudo-1.8.6p3-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:44:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Svensson 2012-08-27 08:32:47 EDT
Description of problem:

When using sudo to change ulmit for a user, we get Operation not permitted after sudo version 1.7.4p5-9


Version-Release number of selected component (if applicable): 1.7.4p5


How reproducible:

rpm --queryformat "%{VERSION}-%{RELEASE}\n" -q sudo 
1.7.4p5-13.el6_3
sudo /bin/su frodo.u -c "bash -c 'ulimit -c unlimited;exit'"
bash: line 0: ulimit: core file size: cannot modify limit: Operation not permitted

rpm --queryformat "%{VERSION}-%{RELEASE}\n" -q sudo 
1.7.4p5-12.el6_3
sudo /bin/su frodo.u -c "bash -c 'ulimit -c unlimited;exit'"
bash: line 0: ulimit: core file size: cannot modify limit: Operation not permitted

rpm --queryformat "%{VERSION}-%{RELEASE}\n" -q sudo 
1.7.4p5-11.el6
sudo /bin/su frodo.u -c "bash -c 'ulimit -c unlimited;exit'"
bash: line 0: ulimit: core file size: cannot modify limit: Operation not permitted

rpm --queryformat "%{VERSION}-%{RELEASE}\n" -q sudo 
1.7.4p5-9.el6_2
sudo /bin/su frodo.u -c "bash -c 'ulimit -c unlimited;exit'"
This works!!! 

  
Actual results:
cannot modify limit: Operation not permitted

Expected results:
The ulimit is changed 

Additional info:
-
Comment 6 Karel Srot 2012-10-17 03:31:27 EDT
I believe this is a duplicate to bug 836242.
Comment 7 Daniel Kopeček 2012-10-17 04:20:33 EDT
(In reply to comment #6)
> I believe this is a duplicate to bug 836242.

True... don't know why I didn't mark it as such.
Comment 11 errata-xmlrpc 2013-02-21 04:44:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0363.html

Note You need to log in before you can comment on or make changes to this bug.