Bug 852058 - group create failing for repository.
group create failing for repository.
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jay Dobies
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 09:17 EDT by Preethi Thomas
Modified: 2013-09-09 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 10:20:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-08-27 09:17:39 EDT
Description of problem:
Creating a group seems to be failing

Version-Release number of selected component (if applicable):
[root@pulp-candidate ~]# rpm -q pulp-rpm-server
pulp-rpm-server-2.0.1-1.fc17.noarch
[root@pulp-candidate ~]# 


How reproducible:


Steps to Reproduce:
1. Run repo uploads groups 
2.
3.
  
Actual results:
[root@pulp-candidate ~]# pulp-admin repo uploads group create --repo-id pulp --group-id test --name test --description test
An unexpected error has occurred. More information can be found in the client
log file ~/.pulp/admin.log.



Expected results:




Additional info:
2012-08-27 09:11:40,267 - ERROR - Client-side exception occurred
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/client/extensions/core.py", line 475, in run
    exit_code = Cli.run(self, args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 891, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 184, in execute
    return self.method(*arg_list, **clean_kwargs)
TypeError: create() takes exactly 1 argument (15 given)
Comment 1 Jay Dobies 2012-08-27 09:27:33 EDT
The command is wrong. There's no "create" after group. The exception is due to the okaara parsing error when it gets a non-flag (there's another bug on this that I can't find right now, but I know it's aligned to 39 or 40).

Can you double check with the right command and close this one out if it works?
Comment 2 Preethi Thomas 2012-08-27 10:20:26 EDT
My bad. Closing it out user error

[root@pulp-candidate ~]# pulp-admin repo uploads group --repo-id pulp --group-id test --name test --description test
+----------------------------------------------------------------------+
                         Package Group Creation
+----------------------------------------------------------------------+

Starting upload of selected packages. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Importing into the repository...
... completed

Deleting the upload request...
... completed

Note You need to log in before you can comment on or make changes to this bug.