Bug 852068 - mandatory=core attribute in Export-Package header makes bundle unresolvable in Eclipse
mandatory=core attribute in Export-Package header makes bundle unresolvable i...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hamcrest (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 09:45 EDT by Severin Gehwolf
Modified: 2012-09-18 12:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 12:21:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (1.36 KB, patch)
2012-08-27 09:47 EDT, Severin Gehwolf
no flags Details | Diff

  None (edit)
Description Severin Gehwolf 2012-08-27 09:45:36 EDT
Description of problem:
The org.mockito.mockito-core bundle imports org.hamcrest and is unresolvable as OSGi bundle due to this.

Version-Release number of selected component (if applicable):
hamcrest-1.1-12.fc17

How reproducible:
Always.

I'm attaching a patch with a proposed fix. If the patch looks alright, feel free to give me commit privileges and I'll push the fix myself. Thanks!
Comment 1 Severin Gehwolf 2012-08-27 09:47:42 EDT
Created attachment 607209 [details]
Proposed fix
Comment 2 Severin Gehwolf 2012-08-27 09:48:26 EDT
Link to pkgdb (just in case): https://admin.fedoraproject.org/pkgdb/acls/name/hamcrest
Comment 3 Severin Gehwolf 2012-09-04 10:00:19 EDT
Any thoughts about this?
Comment 4 Severin Gehwolf 2012-09-17 05:07:38 EDT
David, would you be able to help me?
Comment 5 Severin Gehwolf 2012-09-18 12:21:00 EDT
Fixed with: http://koji.fedoraproject.org/koji/taskinfo?taskID=4499137

Note You need to log in before you can comment on or make changes to this bug.