This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 852082 - running VM in pool does not disappear after permissions has been taken from user
running VM in pool does not disappear after permissions has been taken from user
Status: CLOSED DUPLICATE of bug 850741
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.0.7
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Einav Cohen
Pavel Stehlik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 10:37 EDT by Lukas Svaty
Modified: 2013-03-07 20:50 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-02 06:39:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Svaty 2012-08-27 10:37:10 EDT
Description of problem:
Attached VM in pool in running state does not dissapear when the permissions from wpf has been removed... VM stays in the current running state in both userportal and wpf when trying to shut down the VM from UserPortal (without permissions) or from wpf rhevm.log shows:

2012-08-27 16:27:53,042 SEVERE [org.ovirt.engine.core.common.action.ShutdownVmParameters] (http-0.0.0.0-8443-1) Instantiating ShutdownVmParameters via custom serializer.
2012-08-27 16:27:53,079 INFO  [org.ovirt.engine.core.bll.ShutdownVmCommand] (http-0.0.0.0-8443-1) Running command: ShutdownVmCommand internal: false. Entities affected :  ID: 64cc3efc-bc49-4e96-b948-1995c8a62843 Type: VM
2012-08-27 16:27:53,094 INFO  [org.ovirt.engine.core.bll.ShutdownVmCommand] (http-0.0.0.0-8443-1) VmHandler.cs:ShutdownVmCommand:Perform: entered (Desktop test-1).
2012-08-27 16:27:53,095 INFO  [org.ovirt.engine.core.bll.ShutdownVmCommand] (http-0.0.0.0-8443-1) VmHandler.cs:ShutdownVmCommand:Perform: Cannot shutdown Desktop test-1, status is not up. Stopping instead.
2012-08-27 16:27:53,100 INFO  [org.ovirt.engine.core.bll.StopVmCommand] (http-0.0.0.0-8443-1) Running command: StopVmCommand internal: true. Entities affected :  ID: 64cc3efc-bc49-4e96-b948-1995c8a62843 Type: VM
2012-08-27 16:27:53,103 INFO  [org.ovirt.engine.core.vdsbroker.DestroyVmVDSCommand] (http-0.0.0.0-8443-1) START, DestroyVmVDSCommand(vdsId = 82110ef4-f03b-11e1-a053-001a4a013f07, vmId=64cc3efc-bc49-4e96-b948-1995c8a62843, force=false, secondsToWait=0, gracefully=false), log id: 2f74ecc8

Version-Release number of selected component (if applicable):
ic157

How reproducible:
always

Steps to Reproduce:
1. log to wpf with Admin and to userportal with User
2. in wpf create pool and add user permissions for User
3. when Vm appears in user portal run the VM
4. while the Vm is running remove user permissions in wpf for User
5. try to shutdown VM from userportal
6. try to shutdown VM from wpf
  
Actual results:
VM stays in Virtual Machines tab in user portal in running state

Expected results:
Vm should disappear after next refresh

Additional info:
VM in user portal disappears after few minutes and in wpf its state is set Down
Comment 1 Itamar Heim 2012-08-27 10:42:28 EDT
duplicate of bug 850741?

Note You need to log in before you can comment on or make changes to this bug.