Bug 852092 - NullPointerException in DriftServerServiceImpl.getDriftDefinitions
NullPointerException in DriftServerServiceImpl.getDriftDefinitions
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Inventory, Plugin Container (Show other bugs)
JON 3.1.0
All All
unspecified Severity medium
: ER01
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: 850572
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 11:20 EDT by Charles Crouch
Modified: 2015-02-01 18:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 850572
Environment:
Last Closed: 2014-01-02 15:43:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2012-08-27 11:20:24 EDT
+++ This bug was initially created as a clone of Bug #850572 +++

From Heiko:

(2:35:01 PM) pilhuhn: 14:30:21,072 WARN  [DiscoveryBossBean] Could not perform commit synchronization with agent for server [snert.local]
(2:35:01 PM) pilhuhn: java.lang.RuntimeException: java.lang.NullPointerException
(2:35:09 PM) pilhuhn: Caused by: java.lang.NullPointerException
(2:35:10 PM) pilhuhn: 	at org.rhq.enterprise.server.drift.DriftServerServiceImpl.getDriftDefinitions(DriftServerServiceImpl.java:93)
(3:13:18 PM) pilhuhn: saw that flying by when importing servers that were on the Q for some time. It may be that the resource types have changed since - I may have them discovered yesterday or earlier and did a source build this morning. I can't reproduce it on purpose, jshaughn
(3:14:23 PM) jshaughn: had you been doing anything with drift definitions?
(3:16:18 PM) pilhuhn: no, not at all

--- Additional comment from jshaughn@redhat.com on 2012-08-21 16:50:20 EDT ---

master commit 5ffd6e1eb155bf0208690cce526fb18b832ba344

Make drift def sync more efficient, and possibly avoid an NPE that was
seen intermittently.
- DriftServerServiceImpl.getDriftDefinitions() now only generates
  Map entries for resources with drift definitions, avoiding unnecessary
  list creation and subsequent processing.
- Added jdoc to that effect
- Changed private DriftSyncManager.syncConfigs() to syncDriftDefinitions
  for clarity.



Test Notes:
Inventory Sync testing would be appropriate for this.
Comment 1 Heiko W. Rupp 2013-08-12 07:35:45 EDT
This has been fixed in upstream long time ago and will be in ER1

Note You need to log in before you can comment on or make changes to this bug.