Bug 852107 - String Update: rhn-migrate-classic-to-rhsm output
String Update: rhn-migrate-classic-to-rhsm output
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
:
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-08-27 12:05 EDT by Matt Reid
Modified: 2013-01-07 22:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:59:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0033 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-01-08 03:38:27 EST

  None (edit)
Description Matt Reid 2012-08-27 12:05:01 EDT
Description of problem:

Couple more string updates that we should try to sneak into 5.9 if possible. These are output during migration.

1. System is currently subscribed to: -> 
System is currently subscribed to these RHN Classic channels:

2. Unrecognized channels. Channel to product certificate mapping missing for these channels. ->
No product certificates are mapped to these RHN Classic channels:

3. List of channels for which certs are being copied ->
Installing product certificates for these RHN Classic channels:
*Also, this should be banner-ized (banner-ified?) to match the previous 2 sections*

4. Product certificates copied successfully to /etc/pki/product ->
Product certificates installed successfully to /etc/pki/product.
*should have ending punctuation*
Comment 1 RHEL Product and Program Management 2012-08-27 12:17:13 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Bryan Kearney 2012-08-29 11:05:12 EDT
fixed in master at ecbc20d8fccac980d49af980306ab2b23e42afe0
Comment 5 John Sefler 2012-08-30 12:35:15 EDT
[root@jsefler-59client ~]# rpm -q subscription-manager
subscription-manager-1.0.15-1.git.12.5c3af23.el5

[root@jsefler-59client ~] rhn-migrate-classic-to-rhsm -n -f
Red Hat account: qa@redhat.com
Password: 
System Engine Username: testuser1
Password: 
Org: admin

Retrieving existing RHN Classic subscription information ...
+----------------------------------+
System is currently subscribed to these RHN Classic Channels:
+----------------------------------+
rhel-x86_64-client-5
rhel-x86_64-client-5-beta

+--------------------------------------------------+ 
No product certificates are mapped to these RHN Classic channels:
+--------------------------------------------------+
rhel-x86_64-client-fastrack-5-debuginfo
rhel-x86_64-client-fastrack-5
rhn-tools-rhel-x86_64-client-5

+--------------------------------------------------+ 
Installing product certificates for these RHN Classic channels:
+--------------------------------------------------+
rhel-x86_64-client-5
rhel-x86_64-client-5-beta

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from RHN Classic ...
System successfully unregistered from RHN Classic.

Attempting to register system to Red Hat Subscription Management ...
The system has been registered with id: a8e5798d-a070-40ff-a179-b6beb97cb87f 
System 'jsefler-59client.usersys.redhat.com' successfully registered to Red Hat Subscription Management.


CAN WE MAKE ALL THREE BANNER STRINGS (+---+) EQUAL IN LENGTH?
OKAY, THAT IS VERY COSMETIC.
Moving back to ASSIGNED
Comment 6 Bryan Kearney 2012-09-18 10:33:07 EDT
fixed in master at a9e7feb181f018a3faf036a5b77edca0b78d495b
Comment 8 John Sefler 2012-10-12 10:38:11 EDT
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager-migration
subscription-manager-migration-1.0.22-1.el5


[root@rhsm-accept-rhel5 ~]# rhnreg_ks --serverUrl=https://xmlrpc.rhn.code.stage.redhat.com/XMLRPC --username=qa@redhat.com --password=**** --profilename=rhsm-automation --force --norhnsd --nohardware --nopackages --novirtinfo
[root@rhsm-accept-rhel5 ~]# rhn-channel --add --channel rhel-x86_64-server-fastrack-5 --user qa@redhat.com
Password: 
[root@rhsm-accept-rhel5 ~]# rhn-migrate-classic-to-rhsm --no-auto --force --serverurl=subscription.rhn.stage.redhat.com:443/subscription
Red Hat account: qa@redhat.com
Password: 
System Engine Username: qa@redhat.com
Password: 

Retrieving existing RHN Classic subscription information ...
+----------------------------------+                  <=============== LENGTHEN
System is currently subscribed to these RHN Classic Channels:
+----------------------------------+                  <=============== LENGTHEN
rhel-x86_64-server-5
rhel-x86_64-server-fastrack-5

+-----------------------------------------------------+ 
No product certificates are mapped to these RHN Classic channels:
+-----------------------------------------------------+
rhel-x86_64-server-fastrack-5

+-----------------------------------------------------+ 
Installing product certificates for these RHN Classic channels:
+-----------------------------------------------------+
rhel-x86_64-server-5

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from RHN Classic ...
System successfully unregistered from RHN Classic.

Attempting to register system to Red Hat Subscription Management ...
The system has been registered with id: e6c1e483-447d-4eba-8ed4-c3bbfcdb5b4b 
System 'rhsm-accept-rhel5.usersys.redhat.com' successfully registered to Red Hat Subscription Management.

[root@rhsm-accept-rhel5 ~]# 


FAILED: ALL THREE PAIRS OF BANNER STRINGS (+---+) ARE STILL NOT EQUAL IN LENGTH
Comment 9 Alex Wood 2012-10-15 15:59:31 EDT
commit 665d70a7e70141aa88f29c885b5ccd70784382a3
Author:     Bryan Kearney <bkearney@redhat.com>
AuthorDate: Mon Oct 15 11:57:18 2012 -0400
Commit:     Bryan Kearney <bkearney@redhat.com>
CommitDate: Mon Oct 15 11:57:18 2012 -0400
Comment 12 John Sefler 2012-10-19 15:19:28 EDT
Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-migration
subscription-manager-migration-1.0.23-1.el5


[root@jsefler-rhel59 ~]# rhnreg_ks --serverUrl=https://xmlrpc.rhn.code.stage.redhat.com/XMLRPC --username=qa@redhat.com --password=***** --profilename=rhsm-automation --force --norhnsd --nohardware --nopackages --novirtinfo
[root@jsefler-rhel59 ~]# rhn-channel --add --channel rhel-x86_64-server-fastrack-5 --user qa@redhat.com
Password: 
[root@jsefler-rhel59 ~]# rhn-migrate-classic-to-rhsm --no-auto --force --serverurl=jsefler-f14-candlepin.usersys.redhat.com:8443/candlepin
Red Hat account: qa@redhat.com
Password: 
System Engine Username: testuser1
Password: 
Org: admin

Retrieving existing RHN Classic subscription information ...

+-----------------------------------------------------+ 
System is currently subscribed to these RHN Classic Channels:
+-----------------------------------------------------+
rhel-x86_64-server-5
rhel-x86_64-server-fastrack-5

+-----------------------------------------------------+ 
No product certificates are mapped to these RHN Classic channels:
+-----------------------------------------------------+
rhel-x86_64-server-fastrack-5

+-----------------------------------------------------+ 
Installing product certificates for these RHN Classic channels:
+-----------------------------------------------------+
rhel-x86_64-server-5

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from RHN Classic ...
System successfully unregistered from RHN Classic.

Attempting to register system to Red Hat Subscription Management ...
The system has been registered with id: 7c81bca2-f387-48a6-bbde-af4592ab3039 
System 'jsefler-rhel59.usersys.redhat.com' successfully registered to Red Hat Subscription Management.

[root@jsefler-rhel59 ~]# 


(In reply to comment #0)
> 1. System is currently subscribed to: -> 
> System is currently subscribed to these RHN Classic channels:
VERIFIED

> 2. Unrecognized channels. Channel to product certificate mapping missing for
> these channels. ->
> No product certificates are mapped to these RHN Classic channels:
VERIFIED

> 3. List of channels for which certs are being copied ->
> Installing product certificates for these RHN Classic channels:
VERIFIED
> *Also, this should be banner-ized (banner-ified?) to match the previous 2
> sections*
VERIFIED
 
> 4. Product certificates copied successfully to /etc/pki/product ->
> Product certificates installed successfully to /etc/pki/product.
VERIFIED
> *should have ending punctuation*
VERIFIED


Moving to VERIFIED
Comment 14 RHEL Product and Program Management 2012-10-22 20:18:21 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 16 errata-xmlrpc 2013-01-07 22:59:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.