Bug 852121 - GTK file dialog blocks while preselcting a filename and scrolling
GTK file dialog blocks while preselcting a filename and scrolling
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk2 (Show other bugs)
5.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Benjamin Otte
Desktop QE
: Patch, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 12:21 EDT by Divya
Modified: 2014-06-16 07:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:06:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (2.12 MB, application/x-java-archive)
2012-08-27 12:21 EDT, Divya
no flags Details
Test Case [Reproducer] (1.76 KB, text/x-python)
2013-04-07 09:17 EDT, Siddharth Sharma
no flags Details

  None (edit)
Description Divya 2012-08-27 12:21:05 EDT
Created attachment 607248 [details]
Reproducer

Description of problem:

When a user tries to open a GTK window with a predefined path which has over 25000 files, the GTK window is opened and does not block immediately. However, as soon as user tries to use the scrollbar in the window to scroll down/up the list of files, the entire GTK window becomes unresponsive (blocked) for some long time (minute or more). Issue occurs with following entry in the $HOME/.config/gtk-2.0/gtkfilechooser file:

 <gtkfilechooser>
     <location mode="filename-entry"/>
     <show_hidden value="false"/>
 </gtkfilechooser>

It does not occur with location mode as path-bar instead:

 <gtkfilechooser>
     <location mode="path-bar"/>
     <show_hidden value="false"/>
 </gtkfilechooser>

Version-Release number of selected component (if applicable):
gtk2-2.10.4-21.el5_7.7


How reproducible:
Always

Steps to Reproduce:

1. Run the attached jar file "testCr70816.jar" first time and click on the top leftmost icon (with the tooltip appearing as "Type a file name") to get the "Location:" field. Close the window without doing anything here. Contents of file $HOME/.config/gtk-2.0/gtkfilechooser is changed as filename-entry for location-mode as mentioned in the description:

  <gtkfilechooser>
     <location mode="filename-entry"/>
     <show_hidden value="false"/>
  </gtkfilechooser>

2. Rerun the jar file with above config file intact.
  
Actual results:
While scrolling up/down the file dialog window with large number of files, it freezes.

Expected results:
Initial lag on opening the dialog with the large number of files is acceptable but there should not occur a freeze while scrolling inside the window.

Additional info:
* Issue does not exist on RHEL-6
* GTK window freezes specifically when it is run with the filename-entry in filechooser config as mentioned in the description and  trying to preselect the file name in filechooser list. Commenting/removing the below line, it does not hang:

dialog.setFileName("tmp_" + MAX_FILES / 2);
Comment 1 RHEL Product and Program Management 2012-08-27 12:37:07 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 RHEL Product and Program Management 2012-10-30 01:59:12 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2013-04-04 08:37:35 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 9 Siddharth Sharma 2013-04-07 09:17:44 EDT
Created attachment 732342 [details]
Test Case [Reproducer]
Comment 15 RHEL Product and Program Management 2013-05-31 10:37:48 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 19 RHEL Product and Program Management 2014-02-24 19:16:17 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 20 RHEL Product and Program Management 2014-03-07 07:17:24 EST
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX. To request that Red Hat re-consider this request, please re-open the bugzilla via  appropriate support channels and provide additional business and/or technical details about its importance to you.
Comment 21 RHEL Product and Program Management 2014-06-02 09:06:45 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 22 Divya 2014-06-16 07:20:15 EDT
(In reply to RHEL Product and Program Management from comment #20)
> Thank you for submitting this request for inclusion in Red Hat Enterprise
> Linux 5. We've carefully evaluated the request, but are unable to include it
> in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED
> as WONTFIX. To request that Red Hat re-consider this request, please re-open
> the bugzilla via  appropriate support channels and provide additional
> business and/or technical details about its importance to you.

Case associated with this bug report is closed.

Note You need to log in before you can comment on or make changes to this bug.