Bug 852151 - We need an easy way to alter client configs without breaking DVM
We need an easy way to alter client configs without breaking DVM
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
All Linux
high Severity low
: ---
: ---
Assigned To: krishnan parthasarathi
Sudhir D
: FutureFeature
Depends On: GLUSTER-2014
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 13:41 EDT by Vidya Sakar
Modified: 2015-11-03 18:04 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: GLUSTER-2014
Environment:
Last Closed: 2012-10-07 12:58:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-27 13:41:31 EDT
+++ This bug was initially created as a clone of Bug #763746 +++

Jacob,
  It would be tricky in this version to achieve your requirements. Even though the filesystem supports different read-subvolumes for different clients, the CLI still does not have an interface to express this configuration to the filesystem yet.

Avati

    Hello,

     

    With GlusterFS 3.1, I know how you can configure an environment with 3 replicas of files, but what is not clear to me is what the proper way is to configure GlusterFS clients to use this.  I know you can use mount –t glusterfs server:/volname /mntpoint to mount the volume, but what happens when you have different clients that need to mount it in a different way.  For example,

     

    1.       I have 3 replicas with 1 server on each rack in a datacenter.

    2.       I want to have the clients in a rack read data from a server in the rack and not from the other racks.

    3.       Since there is no ‘vol’ file, using the above mount command all servers in all racks will read from all racks.

     

    In 3.0.x, you would specify the read-subvolume in the mirror volume definition on the client and then mount using the vol file.  Is there a way of having multiple client configurations in 3.1.x?  Or do I have to copy the vol file(/etc/glusterd/vols/volname/volname-fuse.vol) to the clients and mount things that way?  If I do that, will it break DVM?

    Jacob Shucart | Gluster

    Sales Engineer

    E-Mail   : Jacob@gluster.com

    Direct    : (408)770-1504

--- Additional comment from amarts@redhat.com on 2011-06-27 05:13:44 EDT ---

*** Bug 2356 has been marked as a duplicate of this bug. ***

--- Additional comment from amarts@redhat.com on 2011-09-27 01:49:56 EDT ---

Planing to keep 3.4.x branch as "internal enhancements" release without any features. So moving these bugs to 3.4.0 target milestone.
Comment 2 Amar Tumballi 2012-10-07 12:58:17 EDT
makes sense mainly in community product... in RHS, this will be outside the supportable configuration... hence making it 'notabug'...

Note You need to log in before you can comment on or make changes to this bug.