Bug 852173 - Different Default Settings for New Storage Volumes (8GB vs 1GB)
Different Default Settings for New Storage Volumes (8GB vs 1GB)
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Kletzander
:
Depends On:
Blocks: 893740
  Show dependency treegraph
 
Reported: 2012-08-27 14:31 EDT by Matt Reid
Modified: 2013-08-07 08:15 EDT (History)
4 users (show)

See Also:
Fixed In Version: virt-manager-0.9.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 893740 (view as bug list)
Environment:
Last Closed: 2013-08-07 08:15:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Default Size for Custom Path Volumes (33.85 KB, image/png)
2012-08-27 14:31 EDT, Matt Reid
no flags Details

  None (edit)
Description Matt Reid 2012-08-27 14:31:13 EDT
Description of problem:
In Virtual Machine Manager 0.9.4 from Fedora 17, whenever I go to make a new vm, I put it in a custom path (my root partition is small, but I have a lot of space in my home directory) and have to click on the browse button. In that dialog, the default size for a vm differs from the default size suggested if I hadn't gone with a custom path. 

Why is the default size 1gb in one place, and 8gb in the standard flow? I feel like they should either be the same, since 1gb is not enough space to do anything useful with a standard distro, or it should remember my last entry and populate with that instead (I usually add a 0 and go with 10gb, after making the mistake of accepting the default once and having to recreate that vm).

Version-Release number of selected component (if applicable):
virt-manager-0.9.4-1.fc17.noarch

How reproducible:
Always

Steps to Reproduce:
1. Click create new vm
2. enter information until you get to step 4 of 5
3. Notice that default size of disk is 8GB
4. Select 2nd radio button, click Browse button
5. Click New Volume
6. Notice that Storage Volume Quota Max Capacity is 1000MB

  
Actual results:
Default option results in a disk size of 1GB

Expected results:
Default option results in a disk size that matches previous default, 8GB, or at least matches what I manually set it to last time I created a New Storage Volume

Additional info:
Comment 1 Matt Reid 2012-08-27 14:31:50 EDT
Created attachment 607319 [details]
Default Size for Custom Path Volumes
Comment 2 Martin Kletzander 2013-08-07 08:15:04 EDT
Fixed upstream with:

commit 46c8ee58dcc1a057222212ebf09bbc0137f39f77
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Wed Feb 6 17:23:21 2013 +0100

    Match default storage size values

Note You need to log in before you can comment on or make changes to this bug.