Bug 85218 - Problem building QT with g++
Problem building QT with g++
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-26 13:57 EST by Philip Allen
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 15:54:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Allen 2003-02-26 13:57:55 EST
Description of problem: 
 
I edited qt.spec to remove the following lines (to force use of g++): 
 
 pushd mkspecs 
 for i in *-g++ qws/*-g++; do 
    [ -d $i ] || continue 
    TARGET=`echo $i |sed -e 's,g++$,gcc,'` 
    cp -aR $i $TARGET 
    perl -pi -e "s,g\+\+,gcc,g;s,^(QMAKE_LIBS[[:space:]]*=.*),\1 -lsupc++,g" $TARGET/* 
 done 
 popd 
 perl -pi -e 's,^(.*linux.*)-g\+\+(.*),\1-gcc\2,' configure 
 perl -pi -e 's,^(.*CXX.*LFLAGS.*),\1 -lsupc++,' qmake/GNUmakefile.in 
 
Then, run rpmbuild -bb qt.spec 
Build crashes before completion. 
 
Version-Release number of selected component (if applicable): 
qt-3.1.1-4.src.rpm 
     
Actual results: 
[end of build log:] 
 
g++ -c -pipe -fno-exceptions -O2 -march=i386 -mcpu=i686 -DGLX_GLXEXT_LEGACY 
-fno-use-cxa-atexit -fno-exceptions  -DQT_MOC -DQT_NO_CODECS -DQT_LITE_UNICODE 
-DQT_NO_COMPONENT -DQT_NO_STL -DQT_NO_COMPRESS 
-I/share/src/redhat/BUILD/qt-x11-free-3.1.1/mkspecs/linux-g++ -I. -I/usr/include/freetype2 
-I../../include -I../tools -I. -o ./qfileinfo_unix.o ../tools/qfileinfo_unix.cpp 
yacc -d moc.y 
rm -f moc_yacc.cpp moc_yacc.h 
mv -f y.tab.h moc_yacc.h 
mv -f y.tab.c moc_yacc.cpp 
g++ -c -pipe -fno-exceptions -O2 -march=i386 -mcpu=i686 -DGLX_GLXEXT_LEGACY 
-fno-use-cxa-atexit -fno-exceptions  -DQT_MOC -DQT_NO_CODECS -DQT_LITE_UNICODE 
-DQT_NO_COMPONENT -DQT_NO_STL -DQT_NO_COMPRESS 
-I/share/src/redhat/BUILD/qt-x11-free-3.1.1/mkspecs/linux-g++ -I. -I/usr/include/freetype2 
-I../../include -I../tools -I. -o ./moc_yacc.o moc_yacc.cpp 
../../include/qdict.h: In member function `uint QDict<type>::count() const 
   [with type = char]': 
../../include/qvaluelist.h:272:   instantiated from here 
../../include/qdict.h:60: internal error: Illegal instruction 
Please submit a full bug report, 
with preprocessed source if appropriate. 
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions. 
make[1]: *** [moc_yacc.o] Error 1 
make[1]: Leaving directory `/share/src/redhat/BUILD/qt-x11-free-3.1.1/src/moc' 
make: *** [src-moc] Error 2 
error: Bad exit status from /var/tmp/rpm-tmp.99234 (%build)
Comment 1 Jakub Jelinek 2003-02-26 17:43:41 EST
Is that reproduceable, always on the same file same ICE when you retry?
Comment 2 Philip Allen 2003-03-04 14:55:46 EST
yes
Comment 3 Jakub Jelinek 2003-03-04 16:17:12 EST
Then please submit preprocessed source this can be reproduced on.
(add -save-temps option to g++ command line and attach here moc_yacc.ii
it creates).
Comment 4 Jakub Jelinek 2004-10-03 15:54:23 EDT
Preprocessed source has not been provided (and Qt certainly has built
since then). Closing.

Note You need to log in before you can comment on or make changes to this bug.