Bug 852221 - Crash in fuse_thread_proc on Fedora 17
Crash in fuse_thread_proc on Fedora 17
Status: CLOSED DEFERRED
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
3.3.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Raghavendra Bhat
:
: 852224 (view as bug list)
Depends On: 856704
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 18:02 EDT by Joe Julian
Modified: 2014-12-14 14:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 852224 (view as bug list)
Environment:
Last Closed: 2014-12-14 14:40:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Julian 2012-08-27 18:02:22 EDT
In 3.3.0 I'm crashing out of the client (segfault) in fuse_thread_proc on Fedora 17. This started happening after booting to kernel 3.5.2-3.fc17.x86_64.

(gdb) bt full
#0  0x0000000000000000 in ?? ()
No symbol table info available.
#1  0x00007effec4dd5c1 in fuse_thread_proc (data=0xbb0030) at fuse-bridge.c:4072
        mount_point = 0x0
        this = 0xbb0030
        priv = 0xbb0e90
        res = 72
        iobuf = 0xbaeb20
        finh = <optimized out>
        iov_in = {{iov_base = 0x7effdc04ad20, iov_len = 80}, {iov_base = 0x7effed1ec000, 
            iov_len = 131072}}
        msg = <optimized out>
        fuse_ops = 0x7effec6e7f60
        pfd = {{fd = 5, events = 25, revents = 1}, {fd = 7, events = 25, revents = 1}}
        mount_finished = _gf_true
        __FUNCTION__ = "fuse_thread_proc"
#2  0x0000003ea4607d14 in start_thread (arg=0x7effe1f38700) at pthread_create.c:309
        __res = <optimized out>
        pd = 0x7effe1f38700
        now = <optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {139637472593664, 
                -7166573178386444316, 0, 269031178240, 139637472593664, 24, 
                7022506330125438948, -7136376462306635804}, mask_was_saved = 0}}, priv = {
            pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, 
              canceltype = 0}}}
        not_first_call = 0
        pagesize_m1 = <optimized out>
        sp = <optimized out>
        freesize = <optimized out>
#3  0x0000003ea3af167d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
No locals.
Comment 1 Joe Julian 2012-08-27 18:34:08 EDT
I confirmed that rolling back to 3.3.7-1.fc16.x86_64 prevents this crash.
Comment 2 Brian Foster 2012-09-20 14:13:02 EDT
I just gave 3.3.0 a quick whirl on F17 and didn't reproduce a crash with basic I/O. BTW, my updated F17 is at kernel 3.5.3-1. yumdownloader doesn't give me anything for a 3.5.2-3 kernel...

I don't know what operations you're doing to reproduce this, but I can reproduce a crash with an fallocate command (bug 856704). Given the source of this crash (fuse-bridge.c:4072), I suspect this issue could be related. You might want kkeithley's fix from said bug:

2564ab2bc8cd3aa2561e091f72278e480fcef33d
Comment 3 Amar Tumballi 2013-02-20 01:19:14 EST
doesn't seem to be an issue with latest 3.3 branch, or 3.4.x releases.
Comment 4 Raghavendra Bhat 2013-04-03 02:22:26 EDT
*** Bug 852224 has been marked as a duplicate of this bug. ***
Comment 5 Niels de Vos 2014-11-27 09:53:51 EST
The version that this bug has been reported against, does not get any updates from the Gluster Community anymore. Please verify if this report is still valid against a current (3.4, 3.5 or 3.6) release and update the version, or close this bug.

If there has been no update before 9 December 2014, this bug will get automatocally closed.

Note You need to log in before you can comment on or make changes to this bug.