This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 852325 - Add message when changing the Doc Text field
Add message when changing the Doc Text field
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.2
Unspecified Unspecified
low Severity low (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 04:12 EDT by wangjing
Modified: 2016-06-17 17:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.2.4-6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 22:54:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Douglas Silas 2012-09-03 17:56:29 EDT
Instead of a confirmation or dialog, how about a simple text message in, black or red, preferrably small font size, that appears above or below the Doc Type drop-down whenever it is changed without Doc Text first receiving any changes, that says "Doc Text must also be changed to save", or some similar message?

Alternatively, Bugzilla could present a message after a Bugzilla is saved, at the top, saying that the Doc Type changes were not saved because Doc Text was left unchanged. I'm not sure whether Bugzilla places warning or error messages in that location or not.

Although I recognize that the current modus operandi is a bit confusing, one of the alternatives--allowing Doc Text to be saved independently of a Doc Type change--would probably lead to incorrectly-submitted text, even if a dialog presented the message in comment 1 and asked whether to proceed.
Comment 3 Simon Green 2012-09-11 00:50:56 EDT
(In reply to comment #2)
> Instead of a confirmation or dialog, how about a simple text message in,
> black or red, preferrably small font size, that appears above or below the
> Doc Type drop-down whenever it is changed without Doc Text first receiving
> any changes, that says "Doc Text must also be changed to save", or some
> similar message?

This is probably the best approach. Won't work with non JS enabled browsers, but that is the price you pay.

Note You need to log in before you can comment on or make changes to this bug.