Bug 852333 - CLI: remote install package with GPG key does not work.
CLI: remote install package with GPG key does not work.
Status: CLOSED DUPLICATE of bug 791257
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 04:32 EDT by Hayk Hovsepyan
Modified: 2014-01-27 09:04 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 11:23:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2012-08-28 04:32:14 EDT
Description of problem:
After upgrading CFSE 1.0.1, try to install some package with GPG key remotely to client system, it does not install and shows error "Didn't install any keys"


Version-Release number of selected component (if applicable):
qpid-cpp-server-0.14-14.el6_2.x86_64
katello-glue-pulp-0.1.318-1.el6cf.noarch
katello-configure-0.1.111-1.el6cf.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-common-0.1.112-1.el6cf.noarch
katello-cli-0.1.112-1.el6cf.noarch 
m2crypto-0.21.1.pulp-7.el6.x86_64
mod_wsgi-3.3-3.pulp.el6.x86_64
pulp-common-1.0.4-1.el6.noarch
qpid-cpp-client-0.14-14.el6_2.x86_64
pulp-1.0.4-1.el6.noarch
candlepin-tomcat6-0.6.5-1.el6_2.noarch
katello-glue-foreman-0.1.318-1.el6cf.noarch
katello-0.1.318-1.el6cf.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-agent-0.17-1.el6.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
katello-certs-tools-1.0.7-1.el6_3.noarch
candlepin-0.6.5-1.el6_2.noarch
qpid-cpp-server-ssl-0.14-14.el6_2.x86_64
pulp-selinux-server-1.0.4-1.el6.noarch
katello-common-0.1.318-1.el6cf.noarch
katello-glue-candlepin-0.1.318-1.el6cf.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
python-qpid-0.14-7.el6_2.noarch
python-isodate-0.4.4-4.pulp.el6.noarch
qpid-cpp-client-ssl-0.14-14.el6_2.x86_64
katello-selinux-0.1.10-1.el6.noarch
grinder-0.0.143-1pulp_1.0.el6_3.noarch

How reproducible:
always when package has GPG key

Steps to Reproduce:
1. Make sure you have created provider, product, repo, environment, changeset, gpg_key. Repo can be created for example from "http://inecas.fedorapeople.org/fakerepos/zoo3/" which has GPG keys. Make sure that product and repo are created by gpg_key.
2. Sync repo, promote changeset and register your client system.
3. Upgrade you CFSE (from url http://download.devel.redhat.com/brewroot/repos/se-rhel-6-build/latest/x86_64/)
4. Try to install some package remotely on client system by CLI: system packages --install "lion" --org "$orgname" --name "$sysname"
You will see that it does not install package and shows error: "Didn't install any keys" 
  
Actual results:
Error "Didn't install any keys" is shown.

Expected results:
It should download GPG key and install package.

Additional info:
If packages have not GPG key it works OK.
If you import GPG key manually "rpm --import /tmp/RPM-GPG-KEY" from downloaded file, it installs package.
Comment 1 Mike McCune 2012-08-29 11:23:26 EDT

*** This bug has been marked as a duplicate of bug 791257 ***

Note You need to log in before you can comment on or make changes to this bug.