Bug 852353 - [webadmin] Unable to create iscsi storage domain if timeout/disconnect occurs while dialog is open
[webadmin] Unable to create iscsi storage domain if timeout/disconnect occurs...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
All All
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Ayal Baron
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 05:14 EDT by Gadi Ickowicz
Modified: 2016-02-10 14:12 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-28 08:30:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm logs (231.83 KB, application/x-gzip)
2012-08-28 05:14 EDT, Gadi Ickowicz
no flags Details

  None (edit)
Description Gadi Ickowicz 2012-08-28 05:14:18 EDT
Created attachment 607451 [details]
vdsm logs

Description of problem:
When performing an operation on iscsi storage domains from the webadmin such as creating a domain, the dialog can stay open indefinitely. However, if, between the time login is selected for a target and the time "ok" is clicked the server disconnects from the storage (due to timeout/network error/manual disconnect) the webadmin is not aware of this and only sends createVG, which fails.

Logs attached (vdsm) show time between connectStorageServer and createVG is about 17 minutes, and createVG fails (because storage was disconnected from host, may be due to timeout)

Version-Release number of selected component (if applicable):
rhevm-3.1.0-13.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Open dialog click login
2. go to host and disconnect iscsi session
3. click ok in dialog
  
Actual results:


Expected results:


Additional info:
Comment 1 Simon Grinberg 2012-08-28 08:14:51 EDT
Why is that a bug? 

17 minutes is a lot of time.

A web based dialogue may always have expired information/status. Take for example contention when you update a BZ, an expired sessions when a form is open too long on some sites, etc.  

In RHEV there may be many of those situations:
* What happens if you get SPM re-election during this time?
* What happens if one admin is editing a VM and another from a different session just deleted it?
And so on and on.

What is important is to have a proper failure message when the subsequent operation fails. 

So do you get a proper error?  If so then please close as not a bug. If not then change the subject to fix the error message.
Comment 2 Ayal Baron 2012-08-28 08:30:25 EDT
It's impossible and not interesting to handle all these situations.
This can happen right after createVG command was sent and there is nothing to be done about it.
Comment 3 Simon Grinberg 2012-08-28 10:56:26 EDT
(In reply to comment #2)
> It's impossible and not interesting to handle all these situations.
> This can happen right after createVG command was sent and there is nothing
> to be done about it.

Are you referring to comment #1 or #0.
As per comment #1, I fully agree the scenario is not a bug, however I still need to understand whether a proper error message was delivered.
Comment 5 Ayal Baron 2012-08-28 17:56:57 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > It's impossible and not interesting to handle all these situations.
> > This can happen right after createVG command was sent and there is nothing
> > to be done about it.
> 
> Are you referring to comment #1 or #0.
> As per comment #1, I fully agree the scenario is not a bug, however I still
> need to understand whether a proper error message was delivered.

If an improper error is thrown then a bug can be opened but nothing here would indicate that is the case.
Comment 6 Simon Grinberg 2012-08-29 03:50:04 EDT
(In reply to comment #5)
> If an improper error is thrown then a bug can be opened but nothing here
> would indicate that is the case.

(In reply to comment #1)
> What is important is to have a proper failure message when the subsequent
> operation fails. 
> 
> So do you get a proper error?  If so then please close as not a bug. If not
> then change the subject to fix the error message.

Gadi, the above question is for you

Note You need to log in before you can comment on or make changes to this bug.