Bug 852361 - rebalance: open fd migration fails for files with non-root ownership
rebalance: open fd migration fails for files with non-root ownership
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: shishir gowda
:
: 840919 852580 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 05:24 EDT by shishir gowda
Modified: 2013-12-08 20:33 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:25:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shishir gowda 2012-08-28 05:24:30 EDT
Description of problem:
If a file has non-root permissions, and there are open fd;s during rebalance, application see's failures on the fd. There is no corruption reported. After migration of the file, it can be opened.

The problem is that the dst link files are created with root ownership.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1.lauch a vm hosted on glusterfs.
2.add-bricks, and issue a rebalance.
3.vm should see errors.
  
Actual results:


Expected results:


Additional info:
Comment 1 shishir gowda 2012-08-28 05:36:28 EDT
Errors are reported on the vm. Apps fail, or fs errors are reported.
Comment 2 Vijay Bellur 2012-08-29 02:16:09 EDT
CHANGE: http://review.gluster.org/3861 (dht/rebalance: set the correct ownership on the dst file.) merged in master by Anand Avati (avati@redhat.com)
Comment 3 Vijay Bellur 2012-08-30 05:46:00 EDT
CHANGE: http://review.gluster.org/3862 (dht/rebalance: set the correct ownership on the dst file.) merged in release-3.3 by Vijay Bellur (vbellur@redhat.com)
Comment 4 shishir gowda 2012-09-13 05:52:10 EDT
*** Bug 840919 has been marked as a duplicate of this bug. ***
Comment 5 shishir gowda 2012-09-13 05:52:39 EDT
*** Bug 852580 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.