Bug 852389 - dracut-install: ERROR: failed to create directory [...]
dracut-install: ERROR: failed to create directory [...]
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-08-28 07:10 EDT by Richard W.M. Jones
Modified: 2012-09-12 03:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-09-12 03:59:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-08-28 07:10:39 EDT
Description of problem:

Installing a new kernel always gives errors (warnings?) like this:

Downloading Packages:
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : kernel-3.6.0-0.rc3.git2.1.fc18.x86_64                        1/1 
dracut-install: ERROR: failed to create directory '/var/tmp/initramfs.RizSCE/usr/lib64/plymouth/'
dracut-install: ERROR: installing '/usr/lib64/plymouth//text.so'
E: /usr/lib/dracut/dracut-install -D /var/tmp/initramfs.RizSCE /usr/lib64/plymouth//text.so /var/tmp/initramfs.RizSCE
dracut-install: ERROR: failed to create directory '/var/tmp/initramfs.RizSCE/etc/plymouth/'
dracut-install: ERROR: installing '/etc/plymouth//plymouthd.conf'
E: /usr/lib/dracut/dracut-install -D /var/tmp/initramfs.RizSCE /etc/plymouth//plymouthd.conf /var/tmp/initramfs.RizSCE
  Verifying  : kernel-3.6.0-0.rc3.git2.1.fc18.x86_64                        1/1 

  kernel.x86_64 0:3.6.0-0.rc3.git2.1.fc18                                       


Version-Release number of selected component (if applicable):

Various kernels including

How reproducible:

100% (tried it twice)

Steps to Reproduce:
1. Install a kernel using yum.
Actual results:

Errors shown above.

Expected results:

No errors.

Additional info:

I haven't tried booting this kernel.  The initramfs appears
normal sized:

-rw-r--r--. 1 root root 19598183 Aug 28 12:06 initramfs-3.6.0-0.rc3.git2.1.fc18.x86_64.img
Comment 1 Harald Hoyer 2012-09-06 04:39:13 EDT
$ rpm -q dracut plymouth

Does it work with these recent ones?


# dracut -v --force

If you still experience those error messages, can you please attach the stderr output dracut-debug.log of:

# dracut --debug --force 2> dracut-debug.log
Comment 2 Richard W.M. Jones 2012-09-12 03:59:26 EDT
I have a different version of plymouth ...


Anyway with the new version of dracut the error message
seems to have gone (I didn't try updating the kernel

$ sudo dracut -v --force
I: *** Including module: i18n ***
I: *** Including module: plymouth ***
I: *** Including module: btrfs ***
I: *** Including module: crypt ***
I: *** Including module: dm ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: dmraid ***
I: *** Including module: kernel-modules ***
I: Omitting driver nfs_acl
I: Omitting driver nfs
I: Omitting driver nfsv2
I: Omitting driver nfsv3
I: Omitting driver nfsv4
I: Omitting driver nfs_layout_nfsv41_files
I: Omitting driver objlayoutdriver
I: Omitting driver blocklayoutdriver
I: Omitting driver nfsd
I: Omitting driver lockd
I: *** Including module: lvm ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: mdraid ***
I: *** Including module: multipath ***
I: Skipping udev rule: 40-multipath.rules
I: Skipping program $env{MPATH_SBIN_PATH}/multipath using in udev rule 62-multipath.rules as it cannot be found
I: *** Including module: resume ***
I: *** Including module: rootfs-block ***
I: *** Including module: terminfo ***
I: *** Including module: udev-rules ***
I: *** Including module: virtfs ***
I: *** Including module: biosdevname ***
I: *** Including module: systemd ***
I: *** Including module: usrmount ***
I: *** Including module: base ***
I: *** Including module: fs-lib ***
I: *** Including module: shutdown ***
I: *** Including modules done ***
I: *** Installing kernel module dependencies and firmware ***
I: *** Installing kernel module dependencies and firmware done ***
I: *** Resolving executable dependencies ***
I: *** Resolving executable dependencies done***
I: *** hardlinking files ***
I: *** hardlinking files done ***
I: *** Creating image file ***
I: *** Creating image file done ***
I: Wrote /boot/initramfs-3.6.0-0.rc3.git2.1.fc18.x86_64.img:
I: -rw-r--r--. 1 root root 19511643 Sep 12 08:58 /boot/initramfs-3.6.0-0.rc3.git2.1.fc18.x86_64.img

Note You need to log in before you can comment on or make changes to this bug.