Bug 852405 - several services are not enabled in default preset file
several services are not enabled in default preset file
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: Václav Pavlín
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 850249
  Show dependency treegraph
 
Reported: 2012-08-28 08:01 EDT by Petr Lautrbach
Modified: 2012-09-13 05:29 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 850249
Environment:
Last Closed: 2012-09-13 05:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Services to be enabled by default in preset file (5.26 KB, text/plain)
2012-09-12 09:10 EDT, Václav Pavlín
no flags Details

  None (edit)
Description Petr Lautrbach 2012-08-28 08:01:40 EDT
+++ This bug was initially created as a clone of Bug #850249 +++

Fedora 18 changes the way how to work with services in spec files. It introduces new macros - %systemd_post, %systemd_preun and %systemd_postun; which replace scriptlets from Fedora 17 and older (see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd, https://bugzilla.redhat.com/show_bug.cgi?id=850016).


https://fedoraproject.org/wiki/Starting_services_by_default :
    autofs
    avahi
    coda-client
    dbus
    firewalld
    ifplugd
    iscsi-initiator-utils
    isdn4k-utils
    nfs-utils
    NetworkManager
    ocfs2-tools
    openssh-server
    rpcbind
    rp-pppoe
    rsyslog
    sysklogd
    xinetd 


/usr/lib/systemd/system-preset/99-default.preset :
enable avahi-daemon.*
enable gdm.service
disable *
Comment 1 Václav Pavlín 2012-08-29 10:31:54 EDT
There are more packages that need to be added to presets file. We know about this. We will collect them and add them at once.
Comment 2 Marcela Mašláňová 2012-09-07 08:06:46 EDT
Do you think it's wise to wait? I already fixed the cron daemon and push it into F-18 testing. When do you want to change the default preset? It could happen that only gdm/kdm will be enabled after the installation.

I wonder if we shouldn't push all changes in one update with changes into default.preset.
Comment 3 Lennart Poettering 2012-09-11 23:26:08 EDT
In git I have now added entries for:

# System stuff
enable sshd.service
enable atd.service
enable crond.service
enable rpcbind.*
enable rsyslog.*
enable NetworkManager.service
enable avahi-daemon.*

# Desktop stuff
enable accounts-daemon.service
enable rtkit-daemon.service
enable upower.service
enable gdm.service
enable udisks2.service
enable polkit.service

# https://bugzilla.redhat.com/show_bug.cgi?id=850814
enable arp-ethers.service

# https://bugzilla.redhat.com/show_bug.cgi?id=855372
enable mdmonitor.service
enable mdmonitor-takeover.service

That means from the list Petr posted we still miss:

    autofs
    coda-client
    firewalld
    ifplugd
    iscsi-initiator-utils
    isdn4k-utils
    nfs-utils
    ocfs2-tools
    rp-pppoe
    sysklogd
    xinetd

I think it would be safe adding these too to the list, even thought they are not using the macros yet. However, for that I'd need to know their unit names.
Comment 4 Karel Zak 2012-09-12 06:06:14 EDT
Please, add also uuidd to the list of by default enabled services. Thanks.

https://fedorahosted.org/fesco/ticket/949
Comment 5 Václav Pavlín 2012-09-12 09:10:04 EDT
Created attachment 612104 [details]
Services to be enabled by default in preset file

I went through the packages that use systemd services and have created this preset file.

It contains all packages where systemctl enable or chkconfig --add is called.

It does not contain ocfs2-tools because wrt. git it is dead package.

I hope this will at least help to filter all services suitable for default preset file.
Comment 6 Lennart Poettering 2012-09-12 19:08:46 EDT
Ah, thanks Vaclav!

I have now added many from your list to the preset file. But I didn't add all of them since I am quite sure some of them are network facing or require manual configuration and probably don't make sense to be enabled by default or are incompatible with the current policy. For those I'd really prefer if the respective maintainers would file individual bugs.

Examples for the ones I didn't add: pppoe-server.service or nginx.service. I am pretty sure these two are perfect examples of services that should not be enabled by default...

Karel, uidd is added now.

I will close this bug now and hope that maintainers who miss their units in the list will file appropriate bugs.
Comment 7 Petr Lautrbach 2012-09-13 05:01:50 EDT
(In reply to comment #5)
> It contains all packages where systemctl enable or chkconfig --add is called.

"chkconfig --add" doesn't enable a service, it just add the service to the rc.d structure so the list contains several services which shouldn't be enabled by default like cyrus-imapd, dmapd, exim, ...

Please recheck the list against [1] and fix it.


[1] https://fedoraproject.org/wiki/Starting_services_by_default
Comment 8 Petr Lautrbach 2012-09-13 05:19:20 EDT
I haven't check a list which was pushed to git which is already filtered, sorry for the noise.
Comment 9 Marcela Mašláňová 2012-09-13 05:23:11 EDT
fyi https://fedorahosted.org/fesco/ticket/950
Comment 10 Lennart Poettering 2012-09-13 05:29:52 EDT
BTW, I filled this bug:

https://fedorahosted.org/fesco/ticket/950

In order to get the "starting services by default" list cleaned up a bit.

Note You need to log in before you can comment on or make changes to this bug.