Bug 852424 - [6c4b8d02db7b47d67a306a71a72bcc016fbdf183] Write locks return EAGAIN during graph change
[6c4b8d02db7b47d67a306a71a72bcc016fbdf183] Write locks return EAGAIN during g...
Status: CLOSED DUPLICATE of bug 856985
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Raghavendra G
Sudhir D
:
Depends On: 798878
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 09:07 EDT by Vidya Sakar
Modified: 2013-03-03 21:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 798878
Environment:
Last Closed: 2012-10-11 06:33:20 EDT
Type: ---
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-28 09:07:10 EDT
+++ This bug was initially created as a clone of Bug #798878 +++

Description of problem: While running locktests during graph change, the write lock test returned EAGAIN

How reproducible: Consistently


Steps to Reproduce:
1. ./locktests -n 5 -f testfile
2.  gluster volume set testvol  performance.write-behind off

  
Actual results: 
TEST : TRY TO WRITE ON A WRITE LOCK:Master: can't set lock
: Resource temporarily unavailable


Additional info:

Client log-
[2012-03-01 12:57:56.130819] D [fd-lk.c:444:fd_lk_insert_and_merge] 0-fd-lk: new lock requrest: owner = ffff53427a423330, fl_type = F_RDLCK, fs_start = 0, fs_end = 9223372036854775807, user_flock: l_type = F_RDLCK, l_start = 0, l_len = 0
[2012-03-01 12:57:56.130887] W [fd-lk.c:407:print_lock_list] 0-fd-lk: lock list:
[2012-03-01 12:57:56.130911] D [fd-lk.c:419:print_lock_list] 0-fd-lk: owner = ffff53427a423330, cmd = F_SETLK fl_type = F_RDLCK, fs_start = 0, fs_end = 9223372036854775807, user_flock: l_type = F_RDLCK, l_start = 0, l_len = 0, 
[2012-03-01 12:57:57.162526] D [fuse-bridge.c:3151:fuse_setlk_cbk] 0-glusterfs-fuse: Returning EAGAIN Flock: start=0, len=0, pid=0, lk-owner=ffff53427a423330
[2012-03-01 12:57:57.202162] D [fd-lk.c:444:fd_lk_insert_and_merge] 0-fd-lk: new lock requrest: owner = 722b4f18ffffff2a, fl_type = F_RDLCK, fs_start = 0, fs_end = 9223372036854775807, user_flock: l_type = F_RDLCK, l_start = 0, l_len = 0
[2012-03-01 12:57:57.202237] W [fd-lk.c:407:print_lock_list] 0-fd-lk: lock list:
[2012-03-01 12:57:57.202261] D [fd-lk.c:419:print_lock_list] 0-fd-lk: owner = 722b4f18ffffff2a, cmd = F_SETLK fl_type = F_RDLCK, fs_start = 0, fs_end = 9223372036854775807, user_flock: l_type = F_RDLCK, l_start = 0, l_len = 0, 
[2012-03-01 12:57:58.244156] D [fuse-bridge.c:3151:fuse_setlk_cbk] 0-glusterfs-fuse: Returning EAGAIN Flock: start=0, len=0, pid=0, lk-owner=722b4f18ffffff2a

--- Additional comment from junaid@redhat.com on 2012-04-05 04:54:33 EDT ---

For this release we are not handling lock migration on a graph switch.
Comment 2 Amar Tumballi 2012-10-11 06:33:20 EDT
This is a feature missing... and hence marking as dup

*** This bug has been marked as a duplicate of bug 856985 ***

Note You need to log in before you can comment on or make changes to this bug.