Bug 852440 - --alloc anywhere only works with raid1, not raid4, raid5, or raid6
Summary: --alloc anywhere only works with raid1, not raid4, raid5, or raid6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.3
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 832596
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-28 13:43 UTC by RHEL Program Management
Modified: 2012-10-23 11:30 UTC (History)
11 users (show)

Fixed In Version: lvm2-2.02.95-10.el6_3.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-23 11:30:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1399 normal SHIPPED_LIVE lvm2 bug fix update 2012-10-23 15:27:47 UTC

Description RHEL Program Management 2012-08-28 13:43:57 UTC
This bug has been copied from bug #832596 and has been proposed
to be backported to 6.3 z-stream (EUS).

Comment 5 Corey Marthaler 2012-09-10 19:49:19 UTC
Verified these test cases now pass with the latest 6.3.z rpms.

SCENARIO (raid4) - [alloc_anywhere]
Create a 3-way raid4 volume using only 2 physical devices
lvcreate --type raid4 -i 3 -n alloc_anywhere --alloc anywhere -L 150M raid_sanity /dev/sde2:0-1500 /dev/sdf1:0-1500
image0 should be on /dev/sde2
image1 should be on /dev/sdf1
image2 should be on either /dev/sde2 or /dev/sdf1
Deactivating raid alloc_anywhere... and removing


SCENARIO (raid5) - [alloc_anywhere]
Create a 3-way raid5 volume using only 2 physical devices
lvcreate --type raid5 -i 3 -n alloc_anywhere --alloc anywhere -L 150M raid_sanity /dev/sdb1:0-1500 /dev/sdf2:0-1500
image0 should be on /dev/sdb1
image1 should be on /dev/sdf2
image2 should be on either /dev/sdb1 or /dev/sdf2
Deactivating raid alloc_anywhere... and removing


SCENARIO (raid6) - [alloc_anywhere]
Create a 3-way raid6 volume using only 2 physical devices
lvcreate --type raid6 -i 3 -n alloc_anywhere --alloc anywhere -L 150M raid_sanity /dev/sdf2:0-1500 /dev/sdf1:0-1500
image0 should be on /dev/sdf2
image1 should be on /dev/sdf1
image2 should be on either /dev/sdf2 or /dev/sdf1
Deactivating raid alloc_anywhere... and removing


2.6.32-279.el6.x86_64
lvm2-2.02.95-10.el6_3.1    BUILT: Tue Aug 28 09:31:04 CDT 2012
lvm2-libs-2.02.95-10.el6_3.1    BUILT: Tue Aug 28 09:31:04 CDT 2012
lvm2-cluster-2.02.95-10.el6_3.1    BUILT: Tue Aug 28 09:31:04 CDT 2012
udev-147-2.41.el6    BUILT: Thu Mar  1 13:01:08 CST 2012
device-mapper-1.02.74-10.el6_3.1    BUILT: Tue Aug 28 09:31:04 CDT 2012
device-mapper-libs-1.02.74-10.el6_3.1    BUILT: Tue Aug 28 09:31:04 CDT 2012
device-mapper-event-1.02.74-10.el6_3.1    BUILT: Tue Aug 28 09:31:04 CDT 2012
device-mapper-event-libs-1.02.74-10.el6_3.1    BUILT: Tue Aug 28 09:31:04 CDT 2012
cmirror-2.02.95-10.el6_3.1    BUILT: Tue Aug 28 09:31:04 CDT 2012

Comment 7 errata-xmlrpc 2012-10-23 11:30:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1399.html


Note You need to log in before you can comment on or make changes to this bug.