Bug 852458 - copy cluster-sized blocks to the target of live storage migration
copy cluster-sized blocks to the target of live storage migration
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
: ZStream
: 858775 (view as bug list)
Depends On: 844627
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 10:24 EDT by RHEL Product and Program Management
Modified: 2013-01-09 20:07 EST (History)
16 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.295.el6_3.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 05:25:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2012-08-28 10:24:12 EDT
This bug has been copied from bug #844627 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 4 Eduardo Habkost 2012-09-19 13:42:26 EDT
*** Bug 858775 has been marked as a duplicate of this bug. ***
Comment 7 juzhang 2012-10-19 05:34:39 EDT
Reproduced on qemu-kvm-0.12.1.2-2.295.el6_3.2.

Steps
1. boot guest
#/usr/libexec/qemu-kvm -m 8G -smp 8,cores=8,sockets=1,threads=1 -cpu SandyBridge -drive file=/root/RHEL-Server-6.4-64-virtio.qcow2,format=qcow2,if=none,id=drive-virtio-disk0,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio-disk0,id=virtio-blk-pci0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no,vhost=on -device virtio-net-pci,netdev=hostnet0,mac=00:10:1a:61:72:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -uuid 7678e130-f1a7-4157-875a-8defcdb27af7 -rtc base=localtime,clock=host,driftfix=slew  -vnc :1 -M rhel6.3.0 -monitor stdio -qmp tcp:0:4444,server,nowait

2. Do live snap shot
{ "execute": "transaction", "arguments": {'actions': [ { 'type': 'blockdev-snapshot-sync', 'data' : { 'device': 'drive-virtio-disk0', 'snapshot-file': '/root/blockcopy/sn1' } }] } }

3. do mirror
{ "execute" : "__com.redhat_drive-mirror", "arguments" : { "device" : "drive-virtio-disk0", "target" : "/root/blockcopy/sn2", "format": "qcow2", "mode": "absolute-paths"} }

4. shut down guest

Results:
sn2(mirroring target) > sn1(mirroring source)
#ls -sh
16M sn1   81M sn2

Verify on qemu-kvm-rhev-0.12.1.2-2.295.el6_3.4.x86_64.

Steps
1. boot guest
#/usr/libexec/qemu-kvm -m 8G -smp 8,cores=8,sockets=1,threads=1 -cpu SandyBridge -drive file=/root/RHEL-Server-6.4-64-virtio.qcow2,format=qcow2,if=none,id=drive-virtio-disk0,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio-disk0,id=virtio-blk-pci0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no,vhost=on -device virtio-net-pci,netdev=hostnet0,mac=00:10:1a:61:72:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -uuid 7678e130-f1a7-4157-875a-8defcdb27af7 -rtc base=localtime,clock=host,driftfix=slew  -vnc :1 -M rhel6.3.0 -monitor stdio -qmp tcp:0:4444,server,nowait

2. Do live snap shot
{ "execute": "transaction", "arguments": {'actions': [ { 'type': 'blockdev-snapshot-sync', 'data' : { 'device': 'drive-virtio-disk0', 'snapshot-file': '/root/blockcopy/sn3' } }] } }

3. do mirror
{ "execute" : "__com.redhat_drive-mirror", "arguments" : { "device" : "drive-virtio-disk0", "target" : "/root/blockcopy/sn4", "format": "qcow2", "mode": "absolute-paths"} }

4. shut down guest

Results:

sn2(mirroring target) = sn1(mirroring source)
#ls -sh
9.9M sn3  9.9M sn4
Comment 10 errata-xmlrpc 2012-11-01 05:25:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1420.html

Note You need to log in before you can comment on or make changes to this bug.