Bug 852467 - Failed to run VM (due to low storage) is not logged on the events log
Failed to run VM (due to low storage) is not logged on the events log
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Roy Golan
Leonid Natapov
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 10:46 EDT by Miki Kenneth
Modified: 2012-12-04 15:04 EST (History)
9 users (show)

See Also:
Fixed In Version: si20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:04:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miki Kenneth 2012-08-28 10:46:07 EDT
Try running a VM on a low space storage domain.
I get an can't do action, but nothing on the event log.

This is getting even more strange, because in this particular case, sometimes I might be able to run a vm, but a vm from pool never (i guess because of the snapshot...) - in this case a more informative message should be displayed.
Comment 1 Itamar Heim 2012-08-28 13:41:32 EDT
CanDoAction prevents the action from happening interactivly to the user - I'm pretty sure it never gets logged in the audit log?
please fix bug description if this is correct.

for the other use case:
which message are you getting, what exact message do you expected?
Comment 2 Miki Kenneth 2012-08-30 05:53:21 EDT
something like:

"Failed to run VM <name> due to insufficient available storage"
Comment 3 Roy Golan 2012-09-11 08:56:06 EDT
http://gerrit.ovirt.org/7929
Comment 8 Leonid Natapov 2012-11-12 08:13:36 EST
fixed. getting the following error:
"Error while executing action: Cannot run VM. Low disk space on relevant Storage Domain".

Note You need to log in before you can comment on or make changes to this bug.