Bug 852492 - php-gd seems like it doesn't really need t1lib
php-gd seems like it doesn't really need t1lib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 852485
  Show dependency treegraph
 
Reported: 2012-08-28 13:25 EDT by Adam Jackson
Modified: 2016-06-27 11:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-27 11:13:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Jackson 2012-08-28 13:25:23 EDT
Description of problem:

PHP's binding to its embedded copy of gd (sigh) contains interfaces to both t1lib and freetype.  I'm not sure why it would need to do this since freetype can handle Type1 fonts just fine.
Comment 1 Remi Collet 2012-08-29 01:39:12 EDT
All imageps* functions directly rely on t1lib.
* imagepsloadfont
* imagepsfreefont
* imagepsencodefont
* imagepsextendfont
* imagepsslantfont
* imagepstext
* imagepsbbox
Comment 2 Fedora Admin XMLRPC Client 2014-07-16 08:03:16 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Remi Collet 2016-06-27 11:13:24 EDT
Version 7 is now build in rawhide and doesn't use t1lib anymore.

Note You need to log in before you can comment on or make changes to this bug.