Bug 852511 - aeolus-services prints "stoping <service>" instead of "stopping <service>"
aeolus-services prints "stoping <service>" instead of "stopping <service>"
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Steve Linabery
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 14:21 EDT by jliberma@redhat.com
Modified: 2012-12-04 10:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
aeolus-services appended "ing" to stop, start and restart actions. This caused a spelling error with the stop action. This fix corrects the spelling error for the stop action and displays "Stopping [service] ...".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:18:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jliberma@redhat.com 2012-08-28 14:21:01 EDT
Description of problem: aeolus-services script line 43 appends "ing" to stop, start, or restart action. "Stoping" is an incorrect spelling of "stopping."

Version-Release number of selected component (if applicable):
0.8.34-1

How reproducible: always

Steps to Reproduce:
1. Run aeolus-services stop
  
Actual results: prints "stoping <service>"

Expected results: prints "stopping <services>"

Additional info: Also says "statusing" for mongodb, which is not a real word.
Comment 2 Steve Linabery 2012-09-06 11:16:35 EDT
10ad6c51fdbd5249c53477d23883ea38bff004d2 on master, in nightly build
Comment 3 Steve Linabery 2012-09-07 18:08:10 EDT
in build aeolus-configure-2.8.3-1.el6cf
Comment 4 Ronelle Landy 2012-09-20 09:31:51 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

Verified that both spelling error were corrected. Test output is included below:


>>  aeolus-services stop

Stopping ntpd ...
 Success: Shutting down ntpd: [  OK  ]

Stopping imagefactory ...
 Success: Stopping imagefactory: [  OK  ]

Stopping conductor-dbomatic ...
[  OK  ]: Shutting down conductor-dbomatic: [  OK  ]

Stopping aeolus-conductor ...
 Success: Shutting down thin: [  OK  ]

Stopping libvirtd ...
 Success: Stopping libvirtd daemon: [  OK  ]

Stopping deltacloud-core ...
 Success: Shutting down deltacloud-core: [  OK  ]

Stopping httpd ...
 Success: Stopping httpd: [  OK  ]

Stopping postgresql ...
 Success: Stopping postgresql service: [  OK  ]

Stopping iwhd ...
[  OK  ]: Stopping iwhd daemon:  [  OK  ]

Stopping mongod ...
 Success: Stopping mongod: [  OK  ]


[root@qeblade39 sysconfig]# aeolus-services start

Starting mongod ...
 Success: Starting mongod: [  OK  ]

Starting iwhd ...
 Success: waiting for mongod to listen on localhost:27017[  OK  ]
Starting iwhd daemon: [  OK  ]

Starting postgresql ...
 Success: Starting postgresql service: [  OK  ]

Starting httpd ...
 Success: Starting httpd: [  OK  ]

Starting deltacloud-core ...
 Success: Starting deltacloud-core-mock: [  OK  ]

Starting libvirtd ...
 Success: Starting libvirtd daemon: [  OK  ]

Starting aeolus-conductor ...
 Success: Starting thin: [  OK  ]

Starting conductor-dbomatic ...
[  OK  ]: Starting conductor-dbomatic: [  OK  ]

Starting imagefactory ...
 Success: Starting imagefactory: [  OK  ]

Starting ntpd ...
 Success: Starting ntpd: [  OK  ]

Checking status of mongod ...
 Success: mongod (pid 20867) is running...
Comment 6 errata-xmlrpc 2012-12-04 10:18:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.