Bug 852531 - Conductor should redirect you to last-accessed page on forced login
Conductor should redirect you to last-accessed page on forced login
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matt Wagner
Giulio Fidente
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 16:04 EDT by Matt Wagner
Modified: 2012-12-04 10:18 EST (History)
5 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.14-1.el6cf
Doc Type: Bug Fix
Doc Text:
Accessing a specific page in Cloud Engine when logged out would force the user to the Monitor page after login. This fix adds a login redirect. Unauthenticated users accessing a specific page are now redirected after successful login.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:18:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Wagner 2012-08-28 16:04:49 EDT
Description of problem:
If you attempt to access a URL that requires authentication, but are not authenticated, you are redirected to the login page.

After logging in, you _should_ be redirected to the page you were trying to access before logging in. (This is a regression of #782242, but its disposition indicates that a new ticket should be opened.)


How reproducible:
100%


Steps to Reproduce:
1. Ensure you are logged out of Conductor.
2. Visit a URL like /conductor/images
3. Log in.
 

Actual results:
User is on main dashboard page.


Expected results:
User is redirected to the page they tried to access (/conductor/images here)
Comment 1 Matt Wagner 2012-08-31 16:09:23 EDT
Pull request sent: https://github.com/aeolusproject/conductor/pull/28
Comment 2 Matt Wagner 2012-09-05 10:59:31 EDT
commit 730b95c4081bf14a7c1c8afaa26755f64f26c34e
Author: Matt Wagner <matt.wagner@redhat.com>
Date:   Fri Aug 31 15:43:14 2012 -0400

    BZ 852531 - Login redirects to session[:return_to] if set
    
    This fixes a bug where, if a user tried to visit a page without
    logging in, logging in would take them to the pools page, rather
    than the page they had been on previously, as intended.
    
    See https://bugzilla.redhat.com/show_bug.cgi?id=852531
    (cherry picked from commit 278ff3875554d11da79172f7315c39bd741a165c)
Comment 3 Steve Linabery 2012-09-07 18:01:43 EDT
in build aeolus-conductor-0.13.3-1.el6cf
Comment 5 Giulio Fidente 2012-09-25 12:49:28 EDT
works with aeolus-conductor-0.13.14-1.el6cf
Comment 7 errata-xmlrpc 2012-12-04 10:18:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.