Bug 852590 - VNC VMs should not start with QXL display
Summary: VNC VMs should not start with QXL display
Keywords:
Status: CLOSED DUPLICATE of bug 849635
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact:
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-29 02:51 UTC by Qunfang Zhang
Modified: 2014-01-01 08:45 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-29 03:47:26 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Qunfang Zhang 2012-08-29 02:51:04 UTC
Description of problem:
When install or boot a VM with VNC virtual desktop, guest uses QXL driver by default, this will lead to some problem, refer to: bug 851143.
If the component is not correct, please help change it. 

Version-Release number of selected component (if applicable):
RHEVM host:
# rpm -q rhevm
rhevm-3.1.0-12.el6ev.noarch

Host used to launch VMs:

vdsm-4.9.6-27.0.el6_3.x86_64
libvirt-0.9.10-21.el6_3.3.x86_64
qemu-kvm-rhev-0.12.1.2-2.304.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install or boot a guest in rhevm with vnc virtual desktop
2.
3.
  
Actual results:
Guest uses qxl as the default driver for vnc.

Expected results:
Should not use qxl driver.

Additional info:
qemu command line:

/usr/libexec/qemu-kvm -S -M rhel6.3.0 -cpu Conroe -enable-kvm -m 2048 -smp 1,sockets=1,cores=1,threads=1 -name test -uuid eadbf076-6cfe-4686-aa03-50e5c0958250 -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=6Server-6.3.0.2.el6,serial=36363136-3935-4E43-4731-323854484D59_B4:99:BA:BB:2E:3A,uuid=eadbf076-6cfe-4686-aa03-50e5c0958250 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/test.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2012-08-24T15:34:12,driftfix=slew -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x4 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw,serial= -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=/rhev/data-center/8972f022-df5b-42d2-b00d-376d90ba9d68/5a3a822e-d734-41b8-9df9-9e750e153c5f/images/5fa41996-1f37-4531-9e84-3468dcaa7849/5f19f69a-e6fb-478a-b6b6-935c0e7dcffd,if=none,id=drive-virtio-disk0,format=raw,serial=5fa41996-1f37-4531-9e84-3468dcaa7849,cache=none,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=26,id=hostnet0,vhost=on,vhostfd=28 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:42:04:9d,bus=pci.0,addr=0x3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/test.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev pty,id=charconsole0 -device virtconsole,chardev=charconsole0,id=console0 -device usb-tablet,id=input0 -vnc 0:2,password -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6

Comment 2 Itamar Heim 2012-08-29 03:47:26 UTC
probably duplicate of bug 849635 (which is the reverse use case)
added note to test this use case as well in bug 849635

*** This bug has been marked as a duplicate of bug 849635 ***


Note You need to log in before you can comment on or make changes to this bug.