Bug 852612 - guest hang if query cpu frequently during pxe boot
guest hang if query cpu frequently during pxe boot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
:
: 816787 (view as bug list)
Depends On:
Blocks: 798682 983446
  Show dependency treegraph
 
Reported: 2012-08-29 01:46 EDT by xu
Modified: 2013-12-08 19:58 EST (History)
13 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.325.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 983446 (view as bug list)
Environment:
Last Closed: 2013-02-21 02:39:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xu 2012-08-29 01:46:01 EDT
Description of problem:

If guest hang if query cpu frequently during pxe boot, we can get below message from stdio monitor:
kvm: unhandled exit 80000021
kvm_run returned -22

execute "info status" in monitor window, get "VM status: paused (internal-error)" 
Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. boot guest with below command:qemu-kvm -cpu Penryn -smp 1,sockets=1,cores=1,threads=1 -m 4G -enable-kvm -uuid e9551a3c-ccaa-4c4b-8781-39eaf7130e0b -boot order=dcn,once=d -vnc :5 -k en-us -rtc base=localtime,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device usb-tablet,id=input0 -drive file=./RHEL-Server-6.3-64-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=yzWaibVh,cache=none,werror=stop,rerror=stop,aio=native -device ide-drive,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=9a:1b:69:1a:e5:5c,bus=pci.0,addr=0x5,bootindex=3 -monitor stdio -device virtio-balloon-pci,id=balloon1,bus=pci.0,addr=0x7 -qmp tcp:localhost:4444,server,nowait

2. executed "info cpus" in monitor window frequently

  
Actual results:

guest hang and get below error message:
kvm: unhandled exit 80000021
kvm_run returned -22

Expected results:

guest works fine

Additional info:
Comment 2 xu 2012-08-29 02:14:58 EDT
(In reply to comment #0)
> Description of problem:
> 
> If guest hang if query cpu frequently during pxe boot, we can get below
> message from stdio monitor:
> kvm: unhandled exit 80000021
> kvm_run returned -22
> 
> execute "info status" in monitor window, get "VM status: paused
> (internal-error)" 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> Steps to Reproduce:
> 1. boot guest with below command:qemu-kvm -cpu Penryn -smp
> 1,sockets=1,cores=1,threads=1 -m 4G -enable-kvm -uuid
> e9551a3c-ccaa-4c4b-8781-39eaf7130e0b -boot order=dcn,once=d -vnc :5 -k en-us
> -rtc base=localtime,driftfix=slew -device
> piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device usb-tablet,id=input0
> -drive
> file=./RHEL-Server-6.3-64-virtio.qcow2,if=none,id=drive-virtio-disk0,
> format=qcow2,serial=yzWaibVh,cache=none,werror=stop,rerror=stop,aio=native
> -device ide-drive,drive=drive-virtio-disk0,id=virtio-disk0 -netdev
> tap,id=hostnet0,vhost=on -device
> virtio-net-pci,netdev=hostnet0,id=net0,mac=9a:1b:69:1a:e5:5c,bus=pci.0,
> addr=0x5,bootindex=3 -monitor stdio -device
> virtio-balloon-pci,id=balloon1,bus=pci.0,addr=0x7 -qmp
> tcp:localhost:4444,server,nowait
> 
> 2. executed "info cpus" in monitor window frequently
> 
>   
> Actual results:
> 
> guest hang and get below error message:
> kvm: unhandled exit 80000021
> kvm_run returned -22
> 
> Expected results:
> 
> guest works fine
> 
> Additional info:

releated packages info:
gpxe-bootimgs-0.9.7-6.9.el6.noarch
gpxe-roms-0.9.7-6.9.el6.noarch
gpxe-roms-qemu-0.9.7-6.9.el6.noarch
qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64
Comment 3 xu 2012-08-29 03:20:34 EDT
Reporduced on emu-kvm-0.12.1.2-2.307.el6.x86_64  too, gpxe packages are:
gpxe-bootimgs-0.9.7-6.9.el6.noarch
gpxe-roms-qemu-0.9.7-6.9.el6.noarch
gpxe-roms-0.9.7-6.9.el6.noarch

Reporduce steps:

Boot guest from pxe,(it's important that guest must have nic can connect to pxe server and recieve data from pxe server), then execute "info cpus" in monitor windows as quickly as possible;

Thanks,
Xu
Comment 4 xu 2012-08-29 05:55:25 EDT
Disable ept with modproble kvm_intel ept=0, re-test on the macine guest not hang;
Comment 5 Suqin Huang 2012-08-29 05:57:53 EDT
Can reproduce on Westmere host as well, can not reprodue on Penryn host.
Comment 6 Orit Wasserman 2012-08-29 06:26:48 EDT
can you get the output of /proc/cpuinfo
Comment 7 xu 2012-08-29 07:06:23 EDT
(In reply to comment #6)
> can you get the output of /proc/cpuinfo

[root@localhost ~]# cat /proc/cpuinfo 
...
processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
stepping	: 7
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 7
initial apicid	: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 x2apic popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6784.27
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

[root@localhost ~]#
Comment 10 xu 2012-10-17 01:36:23 EDT
Not reproduce this bug with qemu-kvm-0.12.1.2-2.325.el6.x86_64 package, I thinks this bug has fixed;

[root@localhost autotest-devel]# cat /sys/module/kvm_intel/parameters/ept 
Y

CPU Info:processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
stepping	: 7
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 7
initial apicid	: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6784.39
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
Comment 11 Orit Wasserman 2012-10-17 04:40:01 EDT
*** Bug 816787 has been marked as a duplicate of this bug. ***
Comment 12 langfang 2012-11-06 02:23:21 EST
reproduce this bug as follow version:
# uname -r
2.6.32-335.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.316.el6.x86_64

guest:

# uname -r
2.6.32-337.el6.x86_64

1.enable host ept

2.boot guest /usr/libexec/qemu-kvm -M rhel6.4.0 -cpu Penryn -enable-kvm -uuid `uuidgen` -rtc base=utc,clock=host,driftfix=slew -m 4G -smp 2,sockets=1,cores=2,threads=1 -name rhel6.4 -drive file=/lang1/rhel6.4-copy1.raw,if=none,id=drive-virtio-disk0,format=raw,serial=zhang,cache=none,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,drive=drive-virtio-disk0,scsi=off,id=virtio-disk0,bus=pci.0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=04:27:21:42:0b:00,bus=pci.0,addr=0x4 -monitor stdio -boot n -spice disable-ticketing,port=5900,password=redhat -global qxl-vga.vram_size=33554432 -k en-us -vga qxl -qmp tcp:0:4445,server,nowait  -serial unix:/tmp/tty0,server,nowait -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -usbdevice tablet

3. executed "info cpus" in monitor window frequently when boot from PXE

results:
guest hang
(qemu) info status
VM status: paused (internal-error)

verify this bug with version:
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.331.el6.x86_64


steps as same as reproduce

results:
guest can boot normally,guest work well .so this bug has been fixed.
Comment 13 langfang 2012-11-06 03:02:59 EST
addinfo:test more than 15 times on the fixed version ,can not hit the  problem.so this bug fixed.

host:
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.331.el6.x86_64

# uname -r
2.6.32-335.el6.x86_64
Comment 15 errata-xmlrpc 2013-02-21 02:39:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.