Bug 852635 - SDL_mixer not used with _hardened_build set
SDL_mixer not used with _hardened_build set
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freeciv (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 03:54 EDT by Edward Sheldrake
Modified: 2012-09-17 18:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 07:27:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for sound.m4 (479 bytes, patch)
2012-08-29 03:54 EDT, Edward Sheldrake
no flags Details | Diff
patch for configure to avoid running autotools (532 bytes, patch)
2012-08-29 03:56 EDT, Edward Sheldrake
no flags Details | Diff

  None (edit)
Description Edward Sheldrake 2012-08-29 03:54:57 EDT
Created attachment 607798 [details]
fix for sound.m4

Description of problem:
Since _hardened_build was enabled for freeciv, SDL_mixer isn't used, due to the configure script's tests failing

Version-Release number of selected component (if applicable):
freeciv-2.3.2-2.fc17

How reproducible:
Yes.

Steps to Reproduce:
1. Check build logs.
2.
3.
  
Actual results:
Lacking sound via SDL_mixer.

Expected results:
Sound via SDL_mixer.

Additional info:
From config.log, the problem is that -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 has ended up more than once on the gcc command line:

configure:20300: checking SDL_mixer.h usability
configure:20300: gcc -c -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -march=core2 -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -march=core2 -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT conftest.c >&5
gcc: fatal error: /usr/lib/rpm/redhat/redhat-hardened-cc1: attempt to rename spec 'cc1_options' to already defined spec 'rh_cc1_options_old'
compilation terminated.

This is because CFLAGS got added to CPPFLAGS in tests within m4/sound.m4
Comment 1 Edward Sheldrake 2012-08-29 03:56:07 EDT
Created attachment 607800 [details]
patch for configure to avoid running autotools
Comment 2 Gwyn Ciesla 2012-08-29 09:59:52 EDT
Thanks, fix on it's way.
Comment 3 Fedora Update System 2012-08-29 10:30:58 EDT
freeciv-2.3.2-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/freeciv-2.3.2-3.fc18
Comment 4 Fedora Update System 2012-08-29 10:31:09 EDT
freeciv-2.3.2-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/freeciv-2.3.2-3.fc17
Comment 5 Fedora Update System 2012-08-29 14:42:16 EDT
Package freeciv-2.3.2-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freeciv-2.3.2-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12903/freeciv-2.3.2-3.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-09-07 07:27:30 EDT
freeciv-2.3.2-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-09-17 18:26:15 EDT
freeciv-2.3.2-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.