Bug 852692 - [Hyper-V pv drivers] moprobe hv_vmbus on non-Hyper-V(kvm/xen) guest with 5 secs delay
[Hyper-V pv drivers] moprobe hv_vmbus on non-Hyper-V(kvm/xen) guest with 5 se...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.9
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: jason wang
Virtualization Bugs
:
Depends On:
Blocks: 849548
  Show dependency treegraph
 
Reported: 2012-08-29 06:30 EDT by Bian Jinwei
Modified: 2013-01-07 23:42 EST (History)
5 users (show)

See Also:
Fixed In Version: kernel-2.6.18-340.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:42:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bian Jinwei 2012-08-29 06:30:13 EDT
Description of problem:
Install the rhel5.9 with kernel2.6.18-338el5 on the xen/kvm guest,login the rhel5.9 on the xen/kvm platform,execute the command"time modprobe hv_vmbus",then remind you"Init_module call returns -1 with errno 110 - ETIMEDOUT"about 5 secs (real 0m5.013s) delayed.

Version-Release number of selected component (if applicable):
KVM Host: RHEL6.3 release
(Xen host:RHEL5.9 kernel-xen-2.6.18-338.el5)
Guest: RHEL5.9 2.6.18-338.el5

How reproducible:
100%

Steps to Reproduce:
1.Install the xen/kvm guest rhel5.9 with kernel2.6.18-338el5
2.login the guest terminal to execute the command
  # time modprobe hv_vmbus

Actual results:
when you execute the command,the tips:
Init_module call returns -1 with errno 110 - ETIMEDOUT about 5 secs (real 0m5.013s) delayed

Expected results:
when you execute the command,the tips:
"FATAL: Error inserting hv_vmbus(/lib/modules/2.6.18-338.el5/kernel/drivers/hv/hv_vmbus.ko): No such device"with 0.2s(the number just as reference,within 1s delay is ok) s delayed

Additional info:
The problem on physical hypervisor already fixed in bug 849548.
Comment 2 RHEL Product and Program Management 2012-08-30 06:08:35 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 11 Phillip Lougher 2012-09-24 14:15:42 EDT
Patch(es) available in kernel-2.6.18-340.el5
You can download this test kernel (or newer) from http://people.redhat.com/plougher/el5/
Detailed testing feedback is always welcomed.
If you require guidance regarding testing, please ask the bug assignee.
Comment 15 errata-xmlrpc 2013-01-07 23:42:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0006.html

Note You need to log in before you can comment on or make changes to this bug.