Bug 852742 - [ru] Some strings are not translated
[ru] Some strings are not translated
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Localization and Internationalization (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Garik Khachikyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 09:18 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 09:23:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
import_manifest (58.18 KB, image/png)
2012-08-29 10:39 EDT, Garik Khachikyan
no flags Details
dashboard (75.11 KB, image/png)
2012-08-29 11:04 EDT, Garik Khachikyan
no flags Details
create_changeset (59.84 KB, image/png)
2012-08-30 04:05 EDT, Garik Khachikyan
no flags Details
promote_to_environment (35.06 KB, image/png)
2012-08-30 04:08 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Garik Khachikyan 2012-08-29 09:18:46 EDT
Description of problem:
Having a user with default locale: ru I found out that there are some strings not translated (will add comments for later findings)

Version-Release number of selected component (if applicable):
katello-glue-foreman-1.1.7-1.git.176.aad354c.el6.noarch
katello-selinux-1.1.1-1.el6.noarch
katello-agent-1.1.2-1.el6.noarch
katello-repos-1.1.2-1.el6.noarch
qpid-cpp-client-0.14-16.el6.x86_64
qpid-cpp-server-ssl-0.14-16.el6.x86_64
pulp-common-1.1.12-1.el6.noarch
katello-glue-pulp-1.1.7-1.git.176.aad354c.el6.noarch
pulp-1.1.12-1.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-1.1.3-1.git.74.0955126.el6.noarch
qpid-cpp-server-0.14-16.el6.x86_64
qpid-cpp-client-ssl-0.14-16.el6.x86_64
python-oauth2-1.5.170-2.pulp.el6.noarch
katello-certs-tools-1.1.8-1.el6.noarch
candlepin-selinux-0.7.7.1-1.el6.noarch
katello-glue-candlepin-1.1.7-1.git.176.aad354c.el6.noarch
pulp-selinux-server-1.1.12-1.el6.noarch
katello-configure-1.1.5-1.git.22.8372cd6.el6.noarch
candlepin-tomcat6-0.7.7.1-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-common-1.1.3-1.git.74.0955126.el6.noarch
python-qpid-0.14-8.el6.noarch
candlepin-0.7.7.1-1.el6.noarch
katello-common-1.1.7-1.git.176.aad354c.el6.noarch
katello-1.1.7-1.git.176.aad354c.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
mod_wsgi-3.3-3.pulp.el6.x86_64


How reproducible:
always using Katello with RU locale

Steps to Reproduce:
1. create a user (with Administrator role to see everything) with having default locale "ru"
2. Login to katello ui and explore
3.
  
Actual results:
some strings are not translated (see as further comments)

Expected results:
all strings mentioned in the comments should have translated.

Additional info:
Comment 1 Garik Khachikyan 2012-08-29 09:24:26 EDT
# TRANSLATE_RU
Subscriptions - https://<fqdn>/katello/subscriptions
"Import Manifest" button text
"Red Hat Subscriptions" first menu item of the first drop-menu
"Content Search" menu
"Changeset Management" menu
"Changesets History" submenu
Comment 2 Garik Khachikyan 2012-08-29 09:29:23 EDT
# TRANSLATE_RU
Systems - https://<fqdn>/katello/systems
"System Groups" menu
Tooltip for number of sockets (creating new system from UI): "The number of CPU Sockets or LPARs which this machine uses"
"Events History" tab for the already registered system's details.
Comment 3 Garik Khachikyan 2012-08-29 10:39:47 EDT
Created attachment 607921 [details]
import_manifest

# TRANSLATE_RU

Import manifest page (half-not-translated): translate_ru_1.png
Comment 4 Garik Khachikyan 2012-08-29 11:04:19 EDT
Created attachment 607927 [details]
dashboard

# TRANSLATE_RU

Dashboard page (system groups; Administer; Manage Organizations): translate_ru_2.png
Comment 5 Garik Khachikyan 2012-08-30 04:05:35 EDT
Created attachment 608068 [details]
create_changeset

# TRANSLATE_RU

Create Changeset page tooltip: translate_ru_3.png
Comment 6 Garik Khachikyan 2012-08-30 04:08:51 EDT
Created attachment 608069 [details]
promote_to_environment

# TRANSLATE_RU

promote changeset to an env.: translate_ru_4.png
Comment 7 Mike McCune 2013-08-16 13:57:43 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 8 Bryan Kearney 2013-12-16 09:23:46 EST
Closing all i18n bus due to ne architecture. The goal is still a localized UI and CLI, but we will do this via a new round of testing.

Note You need to log in before you can comment on or make changes to this bug.