Bug 85279 - RH8.1Beta3: Problem with libc:futex()
Summary: RH8.1Beta3: Problem with libc:futex()
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-27 12:49 UTC by Andreas Jung
Modified: 2016-11-24 15:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 17:06:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andreas Jung 2003-02-27 12:49:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:
I upgraded from 8.0 to 8.1b3.

Running Zope with Python  had the strange effect that
after the upgrade Zope seems to hang after some HTTP 
request (nothing happens, no new connections were accepted).

I straced Zope and it always hangs here:

such file or directory)
[pid  9547] brk(0)                      = 0x8c89000
[pid  9547] brk(0x8c95000)              = 0x8c95000
[pid  9547] gettimeofday({1046349158, 697639}, NULL) = 0
[pid  9547] gettimeofday({1046349158, 698009}, NULL) = 0
[pid  9547] _llseek(5, 8192, [8192], SEEK_SET) = 0
[pid  9547] read(5, "\10\0\0\0\0\0\0\0Tq\16(h\7U\nDTMLMethodq\17ttQU"..., 4096)
= 4096
[pid  9547] _llseek(5, 12288, [12288], SEEK_SET) = 0
[pid  9547] read(5, "/((U$Products.Sessions.SessionDa"..., 4096) = 4096
[pid  9547] _llseek(5, 69632, [69632], SEEK_SET) = 0
[pid  9547] read(5, "\0\0_getattr_s\10\0\0\0_getattrs\t\0\0\0con"..., 4096) = 4096
[pid  9547] gettimeofday({1046349158, 705371}, NULL) = 0
[pid  9547] write(10, "x", 1)           = 1
[pid  9540] <... select resumed> )      = 1 (in [9], left {29, 990000})
[pid  9547] gettimeofday( <unfinished ...>
[pid  9540] futex(0x8c87ea0, FUTEX_WAIT, 3, NULL <unfinished ...>
[pid  9547] <... gettimeofday resumed> {1046349158, 706733}, NULL) = 0
[pid  9547] futex(0x8c87ea0, FUTEX_WAKE, 1, NULL) = 1
[pid  9547] write(10, "x", 1)           = 1
[pid  9547] futex(0x8c881b0, FUTEX_WAIT, 0, NULL <unfinished ...>
[pid  9544] futex(0x8c87c80, FUTEX_WAIT, 0, NULL <unfinished ...>
[pid  9545] <... futex resumed> )       = 0
[pid  9545] futex(0x8c87b90, FUTEX_WAIT, 0, NULL <unfinished ...>


No idea what's going one here.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Python 2.2.2
2. Install Zope 2.6.1
3. 
    

Additional info:

Comment 1 Alexander 2003-09-12 07:57:33 UTC
The same problems (hanging process in futex call) have been found in RH9. 

1. Suddenly, any running of rpm hangs (fixed by `rm -f /var/lib/rpm/--db*`)

2. And while Oracle 9.2 installation, java machine hangs with this strace:
...
gettimeofday({1063351776, 3307}, NULL)  = 0
futex(0x82cd410, FUTEX_WAKE, 2147483647, {0, 0}) = 1
futex(0x82cce1c, FUTEX_WAKE, 1, {137155584, 1702259060}) = 1
futex(0x809dff4, FUTEX_WAKE, 1, NULL)   = 1
write(9, "\n*** Install Page***", 20)   = 20
clone(child_stack=0x5d139950,
flags=CLONE_VM|CLONE_FS|CLONE_FILES|CLONE_SIGHAND|CLONE_THREAD|CLONE_SETTLS|CLONE_PARENT_SETTID|CLONE_CHILD_CLEARTID|CLONE_DETACHED,
[28496], {entry_number:6, base_addr:0x5d139d30, limit:1048575, seg_32bit:1,
contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) =
28496
futex(0x8323468, FUTEX_WAKE, 2147483647, {0, 0}) = 1
futex(0x84ab9dc, FUTEX_WAKE, 1, {137507928, 0}) = 1
stat64("/tmp/OraInstall2003-09-12_11-28-10AM/oracle/sysman/oii/oiic/OiicInstallActionsPhase$OiInstRun.class",
0xbfffa938) = -1 ENOENT (No such file or directory)
clone(child_stack=0x5e5a2950,
flags=CLONE_VM|CLONE_FS|CLONE_FILES|CLONE_SIGHAND|CLONE_THREAD|CLONE_SETTLS|CLONE_PARENT_SETTID|CLONE_CHILD_CLEARTID|CLONE_DETACHED,
[28497], {entry_number:6, base_addr:0x5e5a2d30, limit:1048575, seg_32bit:1,
contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) =
28497
futex(0x82cf348, FUTEX_WAKE, 2147483647, {0, 0}) = 1
futex(0x84a7364, FUTEX_WAKE, 1, {137163576, 1700147052}) = 1
futex(0x804e18c, FUTEX_WAKE, 1, {137163576, 1700147052}) = 1
futex(0x81a70d0, FUTEX_WAIT, 40, NULL

Comment 2 Ulrich Drepper 2004-09-27 17:06:11 UTC
There have been many different issues wrt to using libpthread since
RHL9.  In libpthread or the programs using it.  AFAIK the current code
is fine.  I'm closing the bug since the information is outdated in any
case.  Should there be a problem in current code, file new bugs.


Note You need to log in before you can comment on or make changes to this bug.