Bug 852807 - Deployment of jboss-brms.war creates a warning with an exception about cxf on EAP 6.0
Deployment of jboss-brms.war creates a warning with an exception about cxf on...
Status: CLOSED DUPLICATE of bug 852679
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRM (Guvnor) (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Mark Proctor
Jiri Svitak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 12:06 EDT by Jiri Svitak
Modified: 2015-06-01 21:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-30 02:42:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (3.31 KB, text/plain)
2012-08-29 12:06 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2012-08-29 12:06:40 EDT
Created attachment 607950 [details]
server.log

This warning occurs while deploying jboss-brms.war on EAP 6.0:

17:52:11,540 WARN  [org.jboss.as.ee] (MSC service thread 1-1) JBAS011006: Not installing optional component org.apache.cxf.transport.http.Servlet3ContinuationProvider$Servlet3Continuation due to exception: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011054: Could not find default constructor for class org.apache.cxf.transport.http.Servlet3ContinuationProvider$Servlet3Continuation

See the whole stack trace in attached server log. Guvnor seems to be working fine, but I am not sure what this warning with the exception might mean or if it could be source of future problems.

To reproduce this issue it should be enough to deploy just single jboss-brms.war on EAP 6.0.

My environment:
EAP 6.0
BRMS 5.3.0 patch01
Comment 1 Lukáš Petrovický 2012-08-30 02:42:45 EDT

*** This bug has been marked as a duplicate of bug 852679 ***

Note You need to log in before you can comment on or make changes to this bug.