Bug 852811 - object-strorage: GET errors out with improper error message
object-strorage: GET errors out with improper error message
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-swift (Show other bugs)
2.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Luis Pabón
pushpesh sharma
:
Depends On: 795614
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 12:26 EDT by Vidya Sakar
Modified: 2016-11-08 17:24 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 795614
Environment:
Last Closed: 2013-09-23 18:32:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-29 12:26:07 EDT
+++ This bug was initially created as a clone of Bug #795614 +++

Description of problem:
GET errors out with an improper message,

[root@RHSSA1 rpms-ready]# curl -v -X GET -H 'X-Auth-Token: AUTH_tk324e52c791cb41b6b80eb91320e05a9f' http://127.0.0.1:8080/v1/AUTH_test/cont1/dir1
* About to connect() to 127.0.0.1 port 8080 (#0)
*   Trying 127.0.0.1... connected
* Connected to 127.0.0.1 (127.0.0.1) port 8080 (#0)
> GET /v1/AUTH_test/cont1/dir1 HTTP/1.1
> User-Agent: curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.12.9.0 zlib/1.2.3 libidn/1.18 libssh2/1.2.2
> Host: 127.0.0.1:8080
> Accept: */*
> X-Auth-Token: AUTH_tk324e52c791cb41b6b80eb91320e05a9f
> 
< HTTP/1.1 503 Internal Server Error
< Content-Type: text/html; charset=UTF-8
< Content-Length: 0
< Date: Mon, 20 Feb 2012 13:35:29 GMT
< 
* Connection #0 to host 127.0.0.1 left intact
* Closing connection #0
Version-Release number of selected component (if applicable):
3.3.0qa22

How reproducible:


Steps to Reproduce:
1.create some subdirs
2.do GET for one of the subdirs
3.
  
Actual results:


Expected results:


Additional info:

--- Additional comment from saujain@redhat.com on 2012-04-05 08:16:41 EDT ---

on original swift the error message is,


< HTTP/1.1 404 Not Found
< Content-Length: 154
< Content-Type: text/html; charset=UTF-8
< Date: Thu, 05 Apr 2012 12:18:32 GMT
< 
<html>
 <head>
  <title>404 Not Found</title>
 </head>
 <body>
  <h1>404 Not Found</h1>
  The resource could not be found.<br /><br />



 </body>
* Connection #0 to host 127.0.0.1 left intact

--- Additional comment from junaid@redhat.com on 2012-05-21 01:52:42 EDT ---

This will be fixed post 3.3 release.
Comment 4 Luis Pabón 2013-07-16 21:01:14 EDT
RHS 2.0 UFO Bugs are being set to low priority.
Comment 5 pushpesh sharma 2013-08-06 06:55:36 EDT
Support for sub directories is now there in RHS2.1. Headers "Content-Type: application/directory" "Content-Length: 0" should be used to create directories. This new way of creating directories has been documented and tested accordingly. 

automated functional tests for the same has been executed with RHS2.1.

#nosetests --exe  ~/gluster-swift/test/functional/gluster_swift_tests.py 
...
----------------------------------------------------------------------
Ran 3 tests in 6.087s

OK
  
[root@dhcp207-149 swift]# rpm -qa|grep swift
gluster-swift-container-1.8.0-6.11.el6rhs.noarch
python-swiftclient-1.4.0-1.el6.noarch
gluster-swift-1.8.0-6.11.el6rhs.noarch
gluster-swift-proxy-1.8.0-6.11.el6rhs.noarch
gluster-swift-account-1.8.0-6.11.el6rhs.noarch
gluster-swift-object-1.8.0-6.11.el6rhs.noarch
gluster-swift-plugin-1.8.0-4.el6rhs.noarch
Comment 8 Scott Haines 2013-09-23 18:32:22 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.