Bug 852826 - Kernel-3.5.x breaks video on Acer Aspire 5670
Kernel-3.5.x breaks video on Acer Aspire 5670
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-08-29 13:17 EDT by Stuart D Gathman
Modified: 2013-04-01 17:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-03-28 09:59:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stuart D Gathman 2012-08-29 13:17:02 EDT
Description of problem:
Video has random pixels replaced with black

Version-Release number of selected component (if applicable):
kernel-3.5.x  (all versions tried)  Last version tried: 3.5.2-3.fc17.i686

How reproducible:

Steps to Reproduce:
1. Boot with 3.5.x kernel
Actual results:
garbage video.  Also, the first 1/2" or so of the rhgb image is black instead of grey - the last pixel row being ragged.

Expected results:
Normal video

Additional info:
All kernels from Fedora 12 through Fedora 16 (2.6 - 3.4.x) worked perfectly.  Only 3.5 is broken.  Booting with a 3.4 kernel from Fedora 17 is the current workaround.  Unfortunately, those are disappearing from repositories, and don't have security patches.  (Can I use the latest kernels from F16 in F17?)

Adding nomodeset to the kernel command line gets "working" video, but is 1024x768 instead of 1280x800 and slower.

This was originally reported in bug#845388 (where 3.5 kernels don't boot at all without nomodeset, but all previous kernels work fine).  That bug has a photo of the garbaged screen. 

Both bugs are in kernel mode set, are worked around with varying success with "nomodeset", and either hang trying to do the kernel mode set during boot, or the KMS doesn't fully work. Many machines are affected, not just the example in the bug report title.  My theory is that KMS is what broke.  There are many machines with KMS problems in 3.5 that never had a problem with previous kernels.  There is a least one bisection done in bug#843826 attachment#605607 [details]  that pinpoints the commit that broke KMS.
Comment 1 Stuart D Gathman 2012-08-29 23:31:47 EDT
Just for grins, I tried 3.6 rc3 from F18.  That causes Xorg to display a solid blue screen.  Text consoles work.
Comment 2 Stuart D Gathman 2012-08-29 23:36:08 EDT
kernel-3.5.3-1 from Koji still broken.
Comment 3 Justin M. Forbes 2012-08-30 12:51:26 EDT
Indeed it is, and we never said that this bug was fixed in the kernel-3.5.3-1 update.  We would like to get it fixed as soon as possible, but it is not making this update.  In fact the fb issue is probably our top priority right now, but also very difficult to debug as it is a race condition only experienced by some.  We do appreciate your testing new kernel and reporting here if it is not fixed, but giving negative karma to an update because your bug still isn't fixed when we have not said it was fixed in that update just delays other bug fixes from getting to users. The fact that this still doesn't work is not a regression from the current stable kernel in F17.  Negative karma is only to be given for regressions from what is currently shipping, or to say something isn't fixed when we have stated that it is in the update. There are 46 other bugfixes included in this update that do help other people.
As for using F16 kernels in F17, yes it works just fine.  The only thing you might miss is some i915 power saving which doesn't exist in F16.  The other workaround that works for most is making sure you remove terminal_output gfxterm from your grub2.cfg.  Basically loading gfxterm forces the vesafb load to begin with, and the deadlock is in the evicting vesafb to install the correct drmfb
Comment 4 Stuart D Gathman 2012-08-30 13:04:44 EDT
I was told that this bug is different than the fb bug (although I do feel intuitively they are related somehow) and to file a new bug.  And it worked in 3.4, so 3.5 was clearly a regression.

So you are saying that while it was a regression when this Acer went from 3.4 to 3.5.2-3 (although too late to leave karma), it is not a regression when it then tries 3.5.3?  And the rule could be: karma is only for the first time you encounter a regression - not for subsequent releases when it still isn't fixed.  

So ideally, karma should only reflect changes from the last release - i.e. negative karma if it is worse than the last release.  In some cases, an update might skip releases, however.

Is that accurate?
Comment 5 Justin M. Forbes 2012-08-30 13:19:53 EDT
Correct. karma is to reflect a negative change from the current stable release (3.5.2-3 at this point). Or, if we explicitly mark a bug as fixed in an update, and that fix is not correct.
Filing a separate bug in this one was the correct thing to do, though the problems are somewhat related.  We really are working to get these fixed. But in the meantime, upstream is also fixing things and getting them into stable releases.  If everyone kept updates from pushing because their bug isn't fixed, no updates would happen, and no bugs would ever get fixed.  If we could do an update and fix every single bug with the current release, we would in an instant.  Unfortunately that doesn't happen, and each update fixes a few bugs here and there.
Comment 6 Stuart D Gathman 2012-08-30 15:32:39 EDT
Removing terminal_output=gfxterm does not fix this bug.
Comment 7 Josh Boyer 2013-03-12 16:29:33 EDT
Are you still seeing this with 3.7.9 or 3.8.2 in updates-testing?
Comment 8 Josh Boyer 2013-03-28 09:59:57 EDT
This bug is being closed with INSUFFICIENT_DATA as there has not been a
response in 2 weeks.  If you are still experiencing this issue,
please reopen and attach the relevant data from the latest kernel you are
running and any data that might have been requested previously.
Comment 9 Stuart D Gathman 2013-04-01 17:33:51 EDT
I just got a chance to check the Acer laptop.  It started working again with the 3.7 kernels.  I'll see if I can them to update to 3.8 and make sure it still works.

Note You need to log in before you can comment on or make changes to this bug.