Bug 852840 - obsolete iptables requirement
obsolete iptables requirement
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iproute (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 854355
  Show dependency treegraph
 
Reported: 2012-08-29 14:00 EDT by Bill Nottingham
Modified: 2012-09-23 23:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-23 23:20:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2012-08-29 14:00:24 EDT
Description of problem:

The iproute spec has:

Requires: iptables >= 1.4.5


1) That's really really old
2) By hardcoding it to the iptables package, it still drags in the iptables commandline tools even if we decide to subpackage the libraries

I think we can drop this line and just have the xtables library requirement pick up iptables (or a theoretical iptables-libs) where necessary.

Version-Release number of selected component (if applicable):

3.5.1-1

How reproducible:

100%
Comment 1 Petr Šabata 2012-08-30 09:04:29 EDT
Alright, I'm okay with this.
Comment 2 Fedora Update System 2012-08-30 10:59:03 EDT
iproute-3.5.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/iproute-3.5.1-2.fc18
Comment 3 Fedora Update System 2012-08-30 14:20:10 EDT
Package iproute-3.5.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing iproute-3.5.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13005/iproute-3.5.1-2.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-09-23 23:20:57 EDT
iproute-3.5.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.