Bug 85293 - RFE: Move Samba User Config to redhat-config-users
RFE: Move Samba User Config to redhat-config-users
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-samba (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
: FutureFeature
: 85830 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-27 11:29 EST by Jim Shanks
Modified: 2007-04-18 12:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 11:38:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Shanks 2003-02-27 11:29:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
I would like to propose this for discussion.

redhat-config-samba is a userfull tool for adding users and shares for Windows
or even Linux clients.  However, I believe that the add-samba-user portion of
this program would be more functional if it was simply added to
redhat-config-users.  A simple "Samba Client?" check box could be added to
redhat-config-users providing a single user configuration program, rather than
having to run multiple programs to add users.

I also would like to propose that a tool (redhat-config-shares) be created to
configure not only Samba shares, but NFS exports as well.  (I realize that NFS
and Samba concepts are quite different, but some single tool to manage all
shares on a box would be quite useful.)  This tool should have the ability to
not only create the shares, but configure the server daemons.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Brent Fox 2003-02-27 12:36:31 EST
On the first part, I agree.  I have not thought of this before, but it seems
like a good idea.  I think we should leave the dialog in redhat-config-samba,
but it would be nice to add a checkbutton to redhat-config-users to
automatically set up the new user as a samba user too.  I guess we would use
their unix password as their samba password as well?

When I started on redhat-config-nfs and redhat-config-samba, I originally set
out to do them as one combined tool because they share the same basic concept of
sharing data between two machines.  As I got into it, though, I realized that it
would be very difficult to do correctly because of how different the underlying
details of NFS and Samba are.  

I came to the conclusion that it would be better to use create one tool for NFS
and one tool for Samba.  I expect these tools to be more suited to a sysadmin
than a desktop user.  

For users who are used to Windows and MacOS, they are used to sharing files
through the file manager.  I think it should be the same for Linux.  I'd like
the user to be able to right-click on a directory in Nautilus and select "Share
 Directory".  Then a dialog pops up and asks them if they want to share with
Unix or share with Windows (or both).  Nautilus could use the backend for
redhat-config-samba and redhat-config-nfs to handle actually setting up the files.

The problem is that sharing files via NFS and Samba requires modifying
/etc/exports and /etc/samba/smb.conf, which means that the desktop user will
need the root password, which they may not have.  That's a little clunky, but
it's better than nothing.

I'm cc'ing our Nautilus maintainer to see what his ideas are on the subject.
Comment 2 Jim Shanks 2003-02-27 14:47:36 EST
I know it adds more complexity, but if "unix password sync = Yes" in the 
smb.conf then using the unix password should be the default action.  If not, 
then a separate password should be provided.

I like the idea of using Nautilius to create shares.  I really wish that 
Nautilus could mount shared volumes.  All you really need to mount volumes with 
Nautilus is to call suid'd smbmnt and smbumount, and create a "mnt" folder in 
the users' home directory to mount the volumes.  example:  If you want to mount 
the share "data" on server "bigguy" you would create the directory 
~/mnt/bigguy/data and then mount the volume with smnmount.  When the share is 
unmounted, remove the directory.  You could even get silly and call the 
directory "~/My\ Network\ Folders/bigguy/data" so that mac and windows users 
would feel a bit more at home.
Comment 3 Alexander Larsson 2003-03-11 08:09:52 EST
Adding a "share this directory" context menu for directories is really simple
with Nautilus now. You just write a context-menu plugin that launches whatever
app you want.

Some time in the future i'd like to do automatic emblems for shared directories.
That needs a lot more changes inside nautilus though.
Comment 4 Alexander Larsson 2003-03-11 09:21:04 EST
*** Bug 85830 has been marked as a duplicate of this bug. ***
Comment 5 Julien Olivier 2003-03-11 09:45:58 EST
About the problem of needing the root password to modify /etc/exports:

Wouldn't it be possible to modify the NFS daemon so that it reads ~/.exports for
example in addition to /etc/exports ? It would let users share _their_own_ files
(or files on which they have sufficiant rights) in addition to system-wide
shared folders.

The second thing is that I think the "share directory" option in Nautilus should
be there even if neither NFS or SAMBA are installed. It should then
automatically install those packages if needed. The reason why I'd like this
behaviour is that most desktop users don't know about NFS or SAMBA. So they
wouldn't install them because they just don't know what it's for.
Comment 6 Nils Philippsen 2006-02-27 11:38:29 EST
This RFE has been open without action for a long time. Closing as DEFERRED to
reflect the actual situation.

Note You need to log in before you can comment on or make changes to this bug.