Bug 852997 - authconfig backup/restore does not work for --enableshadow and --disableshadow
Summary: authconfig backup/restore does not work for --enableshadow and --disableshadow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: authconfig
Version: 6.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: David Spurek
URL:
Whiteboard:
Depends On:
Blocks: 853074
TreeView+ depends on / blocked
 
Reported: 2012-08-30 08:21 UTC by Patrik Kis
Modified: 2015-03-02 05:27 UTC (History)
3 users (show)

Fixed In Version: authconfig-6.1.12-14.el6
Doc Type: Bug Fix
Doc Text:
Cause: Authconfig did not back up /etc/passwd, /etc/group, /etc/shadow, /etc/gshadow files. Consequence: If the authconfig --restorebackup action was used these files were not reverted. Fix: Authconfig now backs these files up. Result: When --restorebackup is used after previous --enable(--disable)shadow --update option used it will properly revert the state of these files.
Clone Of:
: 853074 (view as bug list)
Environment:
Last Closed: 2014-10-14 07:44:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1558 normal SHIPPED_LIVE authconfig bug fix and enhancement update 2014-10-14 01:27:53 UTC

Description Patrik Kis 2012-08-30 08:21:13 UTC
Description of problem:
Authconfig backup/restore does not work for --enableshadow and --disableshadow.
Neither --restorelastbackup nor --savebackup/--restorebackup do their job.
Not all options were tested but --enablenis seems working.
The man page says nothing about exceptions in backup/restore.

Version-Release number of selected component (if applicable):
authconfig-6.1.12-10.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Do a backup
# authconfig --savebackup testback
# sum /etc/shadow* /etc/passwd*
36542     2 /etc/shadow
61955     2 /etc/shadow-
23868     2 /etc/passwd
08119     3 /etc/passwd-

2. Change the shadow configuration
# authconfig --disableshadow --update
# sum /etc/shadow* /etc/passwd*
61955     2 /etc/shadow-
08119     3 /etc/passwd
23868     2 /etc/passwd-

3. Try to restore
# authconfig --restorelastbackup
# echo $?
0
# sum /etc/shadow* /etc/passwd*
61955     2 /etc/shadow-
08119     3 /etc/passwd
23868     2 /etc/passwd-
# 
# authconfig --restorebackup testback
# sum /etc/shadow* /etc/passwd*
61955     2 /etc/shadow-
08119     3 /etc/passwd
23868     2 /etc/passwd-

Actual results:
The original configuration is not restored.

Expected results:
All changes are restored.

Workaround:
# authconfig --enableshadow --update
# sum /etc/shadow* /etc/passwd*
36542     2 /etc/shadow
61955     2 /etc/shadow-
23868     2 /etc/passwd
08119     3 /etc/passwd-

Comment 1 RHEL Program Management 2012-09-07 05:16:27 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 3 Jan Lieskovsky 2013-08-27 16:09:54 UTC
Relevant upstream patch:
  http://hg.fedorahosted.org/hg/authconfig/rev/98d012ea527a

Comment 4 RHEL Program Management 2013-10-14 00:29:41 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 8 errata-xmlrpc 2014-10-14 07:44:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1558.html


Note You need to log in before you can comment on or make changes to this bug.