Bug 853006 - Tip information does not show completely in firstboot's Subscription Registration page
Tip information does not show completely in firstboot's Subscription Registra...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: John Sefler
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-30 05:00 EDT by xingge
Modified: 2016-09-19 22:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:02:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot show the bug (95.10 KB, image/png)
2012-09-19 04:49 EDT, xingge
no flags Details
The "No service levels will cover..." tip is now left justified and does NOT run off the screen. (116.96 KB, image/png)
2012-10-08 18:10 EDT, John Sefler
no flags Details

  None (edit)
Description xingge 2012-08-30 05:00:22 EDT
Description of problem:
Tip information does not show completely in firstboot's Subscription Registration page, 
when register and auto subscribe the system with an account which have no subscriptions to subscribe.

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-1.0.14-1.el5
firstboot-1.4.27.9-1.el5
firstboot-tui-1.4.27.9-1.el5

How reproducible:
always

Steps to Reproduce:
1. prepare an account without any subscriptions to subscribe - in my case, 
I used "stage_test_26" to register to RHEL5.9 Server.
2. Go into firstboot when install a new system or by following steps in a existing system:
2.1 open file /etc/sysconfig/firstboot, then switch the option "RUN_FISRTBOOT" from NO to YES
2.2 reboot the system
3. click "Forward" button until the "Choose Server" page shows
3. make sure the option "Red Hat subscription Management" is selected and click "Forward"
4. input the account's username and password, 
and make sure the "Manually assign subscriptions after registration" is not selected, then click "Forward"
  
Actual results:
A "Subscription Registration" page will show to tell you that no service levels will cover 
all installed products. but the message is too long so that it goes out of the screen. 

Expected results:
The message show completely and correctly.

Additional info:
Comment 1 RHEL Product and Program Management 2012-08-30 05:07:25 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 xingge 2012-09-19 04:49:58 EDT
Created attachment 614265 [details]
Screenshot show the bug
Comment 3 Devan Goodwin 2012-10-01 11:57:44 EDT
Fixed in subscription-manager.git master: f27481ed85b851be4431cf6254ea35d03f261433

awood will pull into 5.9 branches.
Comment 6 John Sefler 2012-10-08 18:10:41 EDT
Created attachment 623770 [details]
The "No service levels will cover..." tip is now left justified and does NOT run off the screen.

Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-firstboot firstboot
subscription-manager-firstboot-1.0.21-1.el5
firstboot-1.4.27.9-1.el5
Comment 8 errata-xmlrpc 2013-01-07 23:02:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.