Bug 853136 - [RFE] copy template action in REST-API
[RFE] copy template action in REST-API
Status: CLOSED DUPLICATE of bug 851099
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
All Unspecified
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Michael Pasternak
Oded Ramraz
storage
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 10:55 EDT by Daniele
Modified: 2016-02-10 15:26 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-02 03:22:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniele 2012-08-30 10:55:19 EDT
1. Proposed title of this feature request
copy template action in REST-API

2. Who is the customer behind the request?
Account name: ASML Netherlands B.V.
Customer segment:
TAM/SRM customer: no
Strategic Customer yes/no: yes

3. What is the nature and description of the request?
They want the "Copy template" action to be available from the REST-API

4. Why does the customer need this? (List the business requirements here)
They have a template-intensive environment. On average 20-50 templates a day will be created with a losely calculated max of 200 a day.
Templates will be created automatically via a script and need to be available on all datastores before they are to be used by the end users. 
Not having the template copy action in the REST-API makes it impossible to automate this process and generates a lot of manual labour.

5. How would the customer like to achieve this? (List the functional
requirements here)
Be able to call the copy template action from the REST-API

6. For each functional requirement listed in question 5, specify how Red Hat
and the customer can test to confirm the requirement is successfully
implemented.


7. Is there already an existing RFE upstream or in Red Hat bugzilla?
No

8. Does the customer have any specific timeline dependencies?
ASAP. They'd like to see it included in 3.1

9. Is the sales team involved in this request and do they have any additional input?


10. List any affected packages or components.


11. Would the customer be able to assist in testing this functionality if
implemented?
Yes
Comment 1 Itamar Heim 2012-08-30 12:23:18 EDT
the supported way of copying the disks of a template to other storage domains is by using the copy disk option?
Comment 3 Michael Pasternak 2012-09-02 03:22:32 EDT

*** This bug has been marked as a duplicate of bug 851099 ***

Note You need to log in before you can comment on or make changes to this bug.