Bug 853175 - debugmode: glibc mcheck does not work (with threads)
debugmode: glibc mcheck does not work (with threads)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
16
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 12:29 EDT by Jan Kratochvil
Modified: 2014-03-16 23:32 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 22:06:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2012-08-30 12:29:30 EDT
Description of problem:
According to
  http://stackoverflow.com/questions/314931/glibcs-lmcheck-option-and-multithreading
  -> http://sourceware.org/bugzilla/show_bug.cgi?id=6547
using MALLOC_CHECK_ breaks programs using threads.
This unfortunately means MALLOC_CHECK_ is not applicable globally at all, it causes false crash positives.

Version-Release number of selected component (if applicable):
debugmode-9.34.3-1.fc16.x86_64

How reproducible:
Did not try myself but just read a bugreport.

Steps to Reproduce:
http://sourceware.org/bugzilla/show_bug.cgi?id=6547

Additional info:
MALLOC_CHECK_ is not applicable, checked also glibc sources PR 6547 is still valid.
MALLOC_PERTURB_ seems to be safe and working according to glibc sources.
G_SLICE=debug-blocks is unrelated and robably still applicable.

I got notified about it in:
  http://sourceware.org/ml/gdb/2012-08/msg00097.html
Comment 1 Bill Nottingham 2012-08-30 12:44:01 EDT
Well, that's dumb. Jeff, any chance that is fixable these days?
Comment 2 Jeff Law 2012-09-18 08:55:45 EDT
Not without a redesign of the interfaces used by malloc_check.  They simply weren't ever designed with multi-threaded access in mind and are inherently broken.

I don't think this has bubbled up high enough on anyone's radar right now.
Comment 3 Bill Nottingham 2012-09-25 01:24:04 EDT
OK, fixed in git.
Comment 4 Fedora Update System 2012-10-05 14:23:36 EDT
initscripts-9.41-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/initscripts-9.41-1.fc18
Comment 5 Fedora Update System 2012-10-06 01:28:29 EDT
Package initscripts-9.41-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initscripts-9.41-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15530/initscripts-9.41-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-10-08 19:54:01 EDT
Package initscripts-9.41-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initscripts-9.41-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15530/initscripts-9.41-2.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-11-15 17:20:18 EST
initscripts-9.37.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/initscripts-9.37.2-1.fc17
Comment 8 Fedora Update System 2012-11-15 17:23:24 EST
initscripts-9.34.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/initscripts-9.34.4-1.fc16
Comment 9 Fedora Update System 2012-11-19 22:06:42 EST
initscripts-9.37.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-11-23 22:30:51 EST
initscripts-9.34.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.