Bug 8532 - Vague error message in RPM
Summary: Vague error message in RPM
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-17 13:19 UTC by Graham Leggett
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 12:21:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Graham Leggett 2000-01-17 13:19:27 UTC
While trying to install the G2 Realplayer from Real Networks, the following
behavior occurred:

[root@veronica /root]# rpm -i G2player-6.0-0.99092901.i386.rpm
error: G2player-6.0-0.99092901.i386.rpm cannot be installed

As can be seen, absolutely no clue whatsoever is given as to why this might
be the case, the error message states the obvious (the install failed) but
then does not go on to state anything useful (like why).

Can this be fixed?

Comment 1 Jeff Johnson 2000-01-17 17:05:59 UTC
Problems like this are usually due to damaged packages. Try

	rpm -K --nopgp --nogpg G2player-6.0-0.99092901.i386.rpm

to verify package integrity.

Comment 2 Jeff Johnson 2000-01-17 17:07:59 UTC
BTW, what version of rpm? You might also try adding "-vv" to the flags
when installing, as that will help pinpoint where the problem is occurring.

Comment 3 Elliot Lee 2000-02-03 20:57:59 UTC
Problem log indicates method of getting better error messages.

Comment 4 Jeff Johnson 2001-05-21 20:04:04 UTC
rpm-4.0.3 displays the sizes of the various components that do not sum
to the expected package size.


Note You need to log in before you can comment on or make changes to this bug.