Bug 853253 - anaconda (textmode) crashes with unexpected input
anaconda (textmode) crashes with unexpected input
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-30 17:08 EDT by David Aquilina
Modified: 2014-06-23 20:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 18:18:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Aquilina 2012-08-30 17:08:17 EDT
Description of problem:

The storage spoke in text mode caused anaconda to die when given input it wasn't expecting, in this case "12" instead of "1":

Traceback (most recent call last):
  File "/sbin/anaconda", line 946, in <module>
    anaconda._intf.run()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/__init__.py", line 159, in run
    self._app.run()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 210, in run
    self._mainloop()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 257, in _mainloop
    if not self.input(self._screens[-1][1], c):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 296, in input
    key = self._screens[-1][0].input(args, key)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/spokes/storage.py", line 207, in input
    self._update_disk_list(self.disks[number -1])
IndexError: list index out of range


The installer died immediately. 

Version-Release number of selected component (if applicable):

anaconda-18.6.3-1.fc18.ppc64
Comment 1 Jesse Keating 2012-08-31 13:39:24 EDT
Yeah, I was expecting that.  Easy enough to fix.
Comment 2 Jesse Keating 2012-08-31 19:35:41 EDT
Patch posted.

Proposing F18Alpha at least NTH.
Comment 3 Fedora Update System 2012-09-01 01:11:27 EDT
anaconda-18.6.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.5-1.fc18
Comment 4 Fedora Update System 2012-09-01 12:56:14 EDT
Package anaconda-18.6.5-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6.5-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13105/anaconda-18.6.5-1.fc18
then log in and leave karma (feedback).
Comment 5 Kamil Páral 2012-09-03 07:19:27 EDT
This is still present in Alpha TC5 (anaconda 18.6.4).
Comment 6 Jesse Keating 2012-09-04 11:58:10 EDT
(In reply to comment #5)
> This is still present in Alpha TC5 (anaconda 18.6.4).

That's why the comment before this says you have to be running anaconda 18.6.5.
Comment 7 Kamil Páral 2012-09-05 04:07:57 EDT
Sure, I know. Still I believe it's better to have that information than not to have it. Sometimes it's fixed in a different build than what the Bodhi update says.
Comment 8 Adam Williamson 2012-09-05 12:45:20 EDT
Discussed at 2012-09-05 blocker review meeting. Accepted as a blocker per criterion "The installer must be able to complete an installation using the text, graphical and VNC installation interfaces", in the case of the user accidentally entering an invalid numerical selection. We felt the chances of someone fat-fingering one of the numerical prompts were pretty high, and the installer really shouldn't crash in this case.
Comment 9 Fedora Update System 2012-09-05 20:52:57 EDT
anaconda-18.6.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Adam Williamson 2012-09-06 12:24:12 EDT
The fix should be in TC6; we should test and verify before closing.
Comment 11 Adam Williamson 2012-09-06 18:18:38 EDT
I can reproduce this at will in TC5 by doing 1 (timezone settings) then 12 (invalid entry) - causes a traceback and reboot. In TC6, same thing just causes the timezone settings screen to be redrawn, as intended. Closing as fixed.

Note You need to log in before you can comment on or make changes to this bug.