Bug 853328 - Need clarification in "9.3. Register the Work Definition" for Guvnor/Designer
Need clarification in "9.3. Register the Work Definition" for Guvnor/Designer
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: Documentation (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Douglas Hoffman
Sona Mala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 01:12 EDT by Toshiya Kobayashi
Modified: 2013-01-20 22:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-20 22:40:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshiya Kobayashi 2012-08-31 01:12:20 EDT
Description of problem:

"9.3. Register the Work Definition" describes how to register custom WorkDefinitons. It's effective for JBDS BPMN2 process editor but not for Guvnor/Designer.

https://access.redhat.com/knowledge/docs/en-US/JBoss_Enterprise_BRMS_Platform/5/html-single/BRMS_Business_Process_Management_Guide/index.html#id3046336

So the request is:

1. Mention that it's an instruction for JBDS BPMN2 process editor
2. Add an explanation for Guvnor/Designer

======
Guvnor/Designer is based on repository so there is no mechanism to pick up the definition from the jar. The sequence is:

- You create and open a BPMN process from Guvnor
- Designer gets the package information from Guvnor via Rest API
- If there is no WorkDefinition in the package, Desinger pushes the default WorkDefinition from designer.war/defaults/WorkDefinitions.wid.st to Guvnor repository
- Once WorkDefinition is stored to repository for the package, Guvnor/Designer will use it. Designer renders Sarvice Task pallete based on the WorkDefinition.
- You can edit the WorkDefinition from Guvnor as described in "5.5. Domain-Specific Service Nodes"
======
Comment 1 Douglas Hoffman 2012-09-14 02:33:55 EDT
Currently moving the BPM Guide into CCMS. Have made a few changes to the Register the Work Definition section. Once I have the rest of the BPM guide transfered over, I will have the information Brewed.
Comment 3 Douglas Hoffman 2012-09-19 21:10:42 EDT
Updated information regarding how custom work item definitions apply to JBoss Developer Studio. The paragraphs have been altered to adjust this minor change within the text; in addition, I linked back to "Defining Domain Specific Service Nodes" to provide information for non-custom Work item Definitions.
Comment 4 Toshiya Kobayashi 2012-09-19 21:57:07 EDT
Hi,

> Changes Brewed to http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_BRMS_Platform/5/html-single/BRMS_Business_Process_Management_Guide/index.html#Register_the_Work_Definition

I think

> "If you are not registering custom work definitions, you can edit work definitions as described in Section 5.6, “Defining Domain-Specific Service Nodes”. "

is not correct wording.

The motivation of this BZ is that "9.3. Register the Work Definition" may cause confision for Guvnor/Designer users because drools.rulebase.conf doesn't work for Guvnor/Designer. So something like "If you want to add/edit work definitions in BRMS user interface, please refer to Section 5.6..." would be fine?
Comment 5 Douglas Hoffman 2012-09-19 23:13:36 EDT
Text changed to "To update work defintions in the JBoss Enterprise BRMS user interface, please refer to Section 5.6 Defining Domain-Specific Service Nodes." Thanks for the heads up.
- Just waiting on Brew update.

Note You need to log in before you can comment on or make changes to this bug.